Topic locked

Applications using vuforia and ARCore just stopped working on some devices

SDK 9.8
August 21, 2021 - 2:04pm #1

Hey guys!

 

4 of my applications just stopped working on my android device (Samsung Galaxy S20+[Exynos]) and display a black screen.

some of my friends (all using Samsung devices) reported the same behavior.

all of the applications previously worked on same device(mine), and weren't updated or modified in any way.

One MRTK app for android also failed to init so it might have something to do with ARCore...

btw, in the editor everything is working fine.

i've tried changing many different ARCore versions, and both including the integrated 1.18 version and a few custom ones.

 

I've already tried building the example project in a new separate project, it had the same result on the device.

After some debugging i found a few things -

* I'm receiving 7 errors, starting with "Positional device tracker failed to initialize." and then the rest is Vuforia failing basically.

after uninstalling Google Services for ARCore, i was able to receive a feed from the camera, though i now got only one error- "SmartTerrain failed to initialize".

I would really appreciate a quick fix, as i mentioned- i have 4 applications failing to start on some devices, 2 of them commercial at the company i work in.



Thanks!

SDK Version: 

Applications using vuforia and ARCore just stopped working on some devices

August 24, 2021 - 5:44am #2

Hey there,

 

I'm sorry for the delay in response. Our R&D team is actively looking into this issue at the moment.

Could you share the 7 error messages you are receiving?

 

Kind regards,

Patrick Scheper

Technical Community Manager

Topic locked