Log in or register to post comments

ARCamera doesn't fill the screen

November 18, 2013 - 4:18am #1

Hi,

I'm developing an Android application using Vuforia and Unity. I was testing it using my Samsung Galaxy S with ICS (4.0.4) and it worked fine.

Last week I changed my device, now I'm using a Nexus 5 with KitKat (4.4). I upgraded Unity (4.3.0) and Android SDK (API 19) to make it work, but I'm facing a problem: the ARCamera doesn't fill the screen (please look at the attached image).

I tried to deploy a new project using the ImageTargets sample and placing only an ARCamera Prefab in my scene, but the result is the same.

Anybody faced the same problem? Do you know how to fix it?

Thank you!

 

 

 

AttachmentSize
Image icon Screenshot_2013-11-18-13-01-35.png288.88 KB

ARCamera doesn't fill the screen

November 18, 2013 - 1:32pm #4

Thank you for answering, I entered directly into the Android forum and missed the green box. I'll be waiting for the next Vuforia release!

ARCamera doesn't fill the screen

November 18, 2013 - 1:19pm #3

For Android there is no workaround at the moment, you will need to wait for the forthcoming release of Vuforia, and switch back to Unity 4.1 or 4.2 for the time being.

 

ARCamera doesn't fill the screen

November 18, 2013 - 11:43am #2

Hi Palouxic,

You're issue is a known problem with Vuforia and the new release of Unity (4.3).  This is mentioned at the root of the forums in a green box that states that the new Unity release is not compatible with Vuforia and there is an iOS workaround to correct the problem.  However, Android's fix is not been made available yet.

@Qualcomm Dev Team:  Is there a way to work around the issue on the Android side for now as we wait for the new release of Vuforia to correct the issue?

Log in or register to post comments