Log in or register to post comments

Armeabi support in Vuforia 2.8

December 18, 2013 - 11:41pm #1

Hello,

I downloaded the SDK of Vuforia 2.8 yesterday and I noticed that there was not libVuforia.so for armeabi, only for armeabi-v7a. Did you guys stop giving support for that specific architecture or am I missing something? I was trying to port my application but this limits the devices that could run it.

I think you guys are doing a great job with this framework.

Thank you,

Cesar.

Armeabi support in Vuforia 2.8

February 20, 2014 - 1:35pm #11

That's great Cesar, Thank you  very much! Appreciated

My email is:

 

Armeabi support in Vuforia 2.8

February 20, 2014 - 1:33pm #10

Oh, they are not available on their web? That is weird, not too much backward compatibility haha Well, that is something that I would complain about, and yeah, I can send them to you. Give me your email or anyway I could send them to you.

Armeabi support in Vuforia 2.8

February 20, 2014 - 1:14pm #9

Thanks Cesar,

 

Sure, I can use the 2.6-2.7 version, it's really basic the funcionality that I need on Android. Do you think you could send me any of those older versions? 

Armeabi support in Vuforia 2.8

February 20, 2014 - 12:56pm #8

I just assumed that they stop supporting armeabi from 2.8. They only support armeabi-v7a. If you really need it, you will have to stick with older versions. 2.6 was the most recent that supported it? I do not remember if it was a 2.7 version. Anyway, if you need help with your project do not hesitate on contacting me! 

 

Cesar.

Armeabi support in Vuforia 2.8

February 20, 2014 - 12:45pm #7

Cesar, 

Did you have some luck finding the armeabi libVuforia.so? I'm really needing it. 

Thanks

Armeabi support in Vuforia 2.8

January 3, 2014 - 1:48am #6

I have confirmed with our engineering team that as of 2.8, Vuforia supports arm v7 only. Note however, that even very old devices already support arm v7.

 

Armeabi support in Vuforia 2.8

December 21, 2013 - 5:00am #5

Let me verify this and get back to you.

Armeabi support in Vuforia 2.8

December 20, 2013 - 1:54pm #4

Thank you for your answer.

I did not check the Getting started guide, but the migration guide. I will look deeper into the exception that I got.

However, to my first question, I did not get an answer.

In Vuforia 2.6 there is a build/lib/armeabi and a build/lib/armeabi-v7a directories. But in Vuforia 2.8 there is only for armeabi-v7a. You guys do not support armeabi anymore?

 

Thanks,

Cesar.

Armeabi support in Vuforia 2.8

December 19, 2013 - 2:50am #3

Have you checked the Gettign Started guide ?

 

Also, the libVuforia.so is contained in:

YOUR_VUFORIA_INSTALL_DIR \ build \ lib \ armeabi-v7a

also, the Vuforia.jar is contained in 

YOUR_VUFORIA_INSTALL_DIR \ build \ java \ vuforia

Armeabi support in Vuforia 2.8

December 19, 2013 - 12:08am #2

Also, I am not sure what I am doing wrong, but it gives me this error

java.lang.NoSuchMethodError: no static method with name='getDeviceOrientation' signature='(Landroid/app/Activity;)I' in class Lcom/qualcomm/ar/pl/SystemTools;
 
I looked up in the documentation and I could not find the getDeviceOrientation method in the class Activity.
 
Thanks,
Cesar.
 
Log in or register to post comments