Log in or register to post comments

Augmentation Rendering for Cloud Recognition service

February 4, 2018 - 12:34am #1

Hi, I'm currently working on the display of 2D image on an image target via Cloud Recognition service. I have modified the "CloudRecoRenderer.java" from the Android VuforiaSample-7-0-43, and it works fine with the default "client access key" and "secretkey", on the "tarmac.jpg" image target. However, the 2D augmented image is not being displayed after I supplied with my own "client access" and "secret" keys. I've uploaded the exact same "tarmac.jpg" into my own cloud database. From the Logcat of the Android Studio, as well as the Target Manager, I can see that the image target was recognised for several times. Does anyone have any idea what could be the possible reasons of the issue? Thank you.

 

Note: The tarmac.jpg that is uploaded to my own cloud database is set with the width "500.0" and is rated with "5 stars".

Augmentation Rendering for Cloud Recognition service

March 5, 2018 - 7:42am #6

I found out that the width of the target needs to be set as 0.3 in the target manager. The app is able to display augmented object now.

Augmentation Rendering for Cloud Recognition service

February 26, 2018 - 4:03am #5

Hi Strasza,

 

Thank you for your reply.

I tried setting the width of "tarmac" image to 320, as well as 120. However, my augmented 2D object still didn't display. I could see that the target was recognised from the target manager and Android Logcat. Besides, the texture was added successfully. as well. Like what I mentioned in my first post, my code works perfectly when I supply the sample client access and secret keys. 

Would you advice me on the width of "tarmac" image set by the default Vuforia sample target manager? 

 

Thank you.

 

 

 

 

Augmentation Rendering for Cloud Recognition service

February 21, 2018 - 2:35pm #4

Hello monkeyhanny,

How big is the target you are trying to detect with in real life measurements? I've observed in the past that setting really high width values for targets (such as the 500 you have set) can cause issues.

Thanks,

Vuforia Support

Augmentation Rendering for Cloud Recognition service

February 21, 2018 - 7:04am #3

Hi,

 

Anyone has any idea about this issue? 

 

Many thanks!

Augmentation Rendering for Cloud Recognition service

February 4, 2018 - 5:24am #2

I have the same issue with you after upgrade my project from unity 2017.2.0 to unity 2017.3.0f3 (vuforia 7.0). Anyone can help us to solve this problem?

Log in or register to post comments