Log in or register to post comments

Black flashes after model if device moving

SDK 10.0
September 13, 2021 - 4:38am #1

1.Create default new project

2. Place default ARCamera, delete MainCamera

3. Create ImageTarget, fill with sprite

4. Create any default object (sphere in such case), scale it to 0.1 xyz

Ok, target recognized, sphere starts to draw - but if we move device, we have a black-sphere shaped track after normaly rendered sphere. What's wrong?

The "examples" works correctly on this device.

SDK Version: 

Black flashes after model if device moving

September 21, 2021 - 4:57am #5

Any Ideas?

Black flashes after model if device moving

September 16, 2021 - 12:30am #4

Looks like a model drawn at current frame in good state, but drawn in whole black(color of "clear") at frame -1,-2,-3 .... and "clear" is called not before each frame, but at unknown time peroid.

exactly....

frame 1 - camera (fone,below all), model (good) top

frame2(next) - camera (below all), model from frame 1 cleared by color of clear, model current frame (good) top

frame3(next) - camera (below all), model from frame 1+frame2 cleared by color of clear, model current frame (good)

...

time to clear!

Frame 1 ....

Black flashes after model if device moving

September 15, 2021 - 3:12am #3

Here. Without Library&Packages (too fat).

Viuforia 10.1.4

Unity 2020.3.17f1

AttachmentSize
Package icon zzzz.zip85.37 KB

Black flashes after model if device moving

September 14, 2021 - 3:16am #2

Hey,

 

If the examples work on the device then it might be your scene. Would you be able to zip your project and share it?

Which Unity version are you using? Also are you using v10.0 or v10.1?

Thanks!  

 

Kind regards,

Patrick Scheper

Technical Community Manager

Log in or register to post comments