Log in or register to post comments

Black screen in 3 second when play fullsceen.

November 6, 2014 - 8:22pm #1

Hi all,

I have proplem with play video in fullscreen mode.

I load video from url in to metadata.

I set my video in auto play and when tap into screen, video will change to fullscreen mode. But after tap, black screen appear in about 3 second, then video play.

So, can you show me why i take this issus and how to reduce the time of black screen.

Thanks so much. 

Black screen in 3 second when play fullsceen.

November 10, 2014 - 6:47pm #3

AlessandroB wrote:

It sounds like the app is loading / retrieving the video from the URL and this may introduce a little delay in the playback.

The Vufora VideoPlayback sample performs fullscreen video playback using standard Android SDK API (not a Vuforia API), in particular the MediaPlayer class; the Android MediaPlayer class for fullscreen playback is used in the sample class FullscreenPlayback.java. 

Have you already searched the Android SDK documentation or some Android specific forums  for a possible hint on this issue ?

Thanks for your answers.
 
I know, i realy use Android sdk api in FullscreenPlayback.java. I have the url of video when parser metadata get from maker in VideoPlayback.java and i want load/stream that video for when start activity FullscreenPlayback.java the video will play instantly without reload. this is my idea, you have any suggest for me ??? thanks

 

Black screen in 3 second when play fullsceen.

November 10, 2014 - 5:23am #2

It sounds like the app is loading / retrieving the video from the URL and this may introduce a little delay in the playback.

The Vufora VideoPlayback sample performs fullscreen video playback using standard Android SDK API (not a Vuforia API), in particular the MediaPlayer class; the Android MediaPlayer class for fullscreen playback is used in the sample class FullscreenPlayback.java. 

Have you already searched the Android SDK documentation or some Android specific forums  for a possible hint on this issue ?

 

 

Log in or register to post comments