Log in or register to post comments

Camera sees marker but screen is black

June 27, 2015 - 6:44am #1

The marker shows, but camera isnt working. unity 5.1.0p1 Vuforia 4.2.3

Ive tried changing around settings, sometimes I get a split screen where half screen reacts to light, and half is black; the screen is split in two equal triangles testing on note 4 Most of time the whole screen is black. 

In both cases when the camera see imagine it shows marker, but it is very laggy and freezes if moved too much.

I dont know much about game development so if there is a post with basic unity/build settings please link. 

Camera sees marker but screen is black

June 30, 2015 - 6:15am #6

@AlbertDupond:

The 64bit architecture error mesage you are seeing suggests that maybe you are using the 64bit version of the Unity 5 Editor on Windows;

please note that Vuforia 4.2 supports the 64bit version of the Unity Editor on Mac OS, while on Windows it requires the 32-bit version of the Unity Editor.

Camera sees marker but screen is black

June 30, 2015 - 6:09am #5

making sure when you got to build hit player settings, go to API in player setting. automatic API should be unchecked. there should be a drop down box with a + and - click ES 3 and hit the - es2 should be only one in that box

Camera sees marker but screen is black

June 29, 2015 - 5:37pm #4

I've got the exact same problem (screen divided in two triangles with one reacting to light) but tweaking graphic API didn't change anything.

I'm building on Nexus 10, my app worked fine with Vuforia 3 & Unity 4, with the Vuforia upgrade steps here :

https://developer.vuforia.com/library/articles/Solution/How-To-Migrate-a-Unity-Project

I got it working in Vuforia 4 / Unity 5 on iPad but now Android camera is just broken on tablet and I have this error in the Editor :

Failed to load 'Assets/Plugins/QCARWrapper.dll', expected 64 bit architecture (IMAGE_FILE_MACHINE_AMD64), but was IMAGE_FILE_MACHINE_I386. You must recompile your plugin for 64 bit architecture.

Anyone got an idea ?

Camera sees marker but screen is black

June 27, 2015 - 8:34am #3

Solved:>- Graphics APIs is set to OpenGL ES 2.0 make sure to subtract es3 from drop down menu

Camera sees marker but screen is black

June 27, 2015 - 8:06am #2

I just tried building in PC the app has  a black screen as well and doesnt recognize tracker at all. In fact I it doubt turns on the camera. I must have something mis configuered or vuforia/unity problem.

Log in or register to post comments