Topic has a solution and is locked
Topic locked

Cannot run sample

January 13, 2022 - 8:13am #1
Topic solved

When I am running sample app on version 10.3.2 on Android 5.1 I got this error. (I am running on Vuzix Blade)

E/art: dlopen("/data/app/com.vuforia.engine.native_sample-1/lib/arm/libVuforiaSample.so", RTLD_LAZY) failed: dlopen failed: empty/missing DT_HASH in "libVuforiaEngine.so" (built with --hash-style=gnu?)
D/AndroidRuntime: Shutting down VM
E/AndroidRuntime: FATAL EXCEPTION: main
    Process: com.vuforia.engine.native_sample, PID: 4206
    java.lang.UnsatisfiedLinkError: dlopen failed: empty/missing DT_HASH in "libVuforiaEngine.so" (built with --hash-style=gnu?)
        at java.lang.Runtime.loadLibrary(Runtime.java:371)
        at java.lang.System.loadLibrary(System.java:988)
        at com.vuforia.engine.native_sample.MainActivity.<clinit>(MainActivity.kt:50)
        at java.lang.reflect.Constructor.newInstance(Native Method)
        at java.lang.Class.newInstance(Class.java:1606)
        at android.app.Instrumentation.newActivity(Instrumentation.java:1066)
        at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:2226)
        at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:2387)
        at android.app.ActivityThread.access$800(ActivityThread.java:151)
        at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1303)
        at android.os.Handler.dispatchMessage(Handler.java:102)
        at android.os.Looper.loop(Looper.java:135)
        at android.app.ActivityThread.main(ActivityThread.java:5254)
        at java.lang.reflect.Method.invoke(Native Method)
        at java.lang.reflect.Method.invoke(Method.java:372)
        at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:902)
        at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:697)

 

But if I am running on mobile phone with Android 9.0 everything works fine

Cannot run sample

January 14, 2022 - 9:38am #3

Thanks. I managed to run SDK version 9 on Vuzix Blade but not 10

Cannot run sample

January 14, 2022 - 2:55am #2

Hey there,

 

That's probably because the Vuzix Blade is not a recommended device. Only the Vuzix 400 is recommended: https://library.vuforia.com/platform-support/recommended-devices

 

Kind regards,

Patrick Scheper

Technical Community Manager

Topic locked