Log in or register to post comments

Change Image of Sample: ImageTargets

March 24, 2013 - 12:18pm #1

Hello,

i have uploaded an Image ( Png-File)  with the TargetManager.

The Image became 3Stars (Quality).

Than i downloaded the Zip file.

And than i put the my.dat and my.xml Files in the ResouresFile.

Than i open the jniFile and opened the ImageTargets.cpp

There i changed the: dataSetStonesAndChips->load("StonesAndChips.xml"   TO dataSetStonesAndChips->load("my.xml"

After this all, i exported the apk to my phone but if i start the app i dont get the Teapot on my Picture.

What did i wrong.

 

 

Change Image of Sample: ImageTargets

March 25, 2013 - 3:00am #6

Glad to help ;-)

 

Change Image of Sample: ImageTargets

March 25, 2013 - 2:44am #5

Hi AlessandroB,

thank you,now its working. Great!! :-)

My mistake, i put that .xml and .dat in to the jni, OHHHH  no.

When you are in Germany i will spend you an Coffee for this ;-)

 

best,

 

Binjam

http://3dxxl.jimdo.com/

Change Image of Sample: ImageTargets

March 25, 2013 - 2:07am #4

Hi, if it failed to load the dataset this might indicate that the app does not find the dataset at runtime; are you sure you copied both the XML and the DAT files into your "assets" directory under the sample project ?

I have also written a step-by-step guide here, please could you verify all the steps once again ?

https://developer.vuforia.com/forum/faq/android-how-do-i-replace-dataset-image-targets-sample

 

Change Image of Sample: ImageTargets

March 25, 2013 - 1:40am #3

Hi,

i made two ways.

One where i first build the ndk and than the changes in the ImageTargets.cpp with refresh Eclispe.

And second changes the ImageTargets.cpp and than the ndk-build also refresh Eclipse.

It works finde without the changes in the ImageTargets.cpp.

But now i get the error Message on my Phone:Failed to initialice QCAR and after press Start always Failed to load tracker data.

(Yes i always, uninstall the old ImageTarget on my Phone)

Change Image of Sample: ImageTargets

March 24, 2013 - 2:58pm #2

Hi,

two quick things to check:

- have you run ndk-build after changing the code in ImageTargets.cpp ? was the build successfull ?

- have you refreshed Eclipse project after successfully building with ndk-build ?

Also, sometimes it might be useful to manually uninstall the old Image Targets from you phone before installing the new one.

Last thing: make sure to tap on the screen of your phone to focus the camera on the target; if the camera is not focussing on the target, the image might be blurry and the detection might become a bit more difficult (especially as you don't have 4 or 5 star targets)

 

Log in or register to post comments