Log in or register to post comments

In Cloudreco sample, addition of new database shows error

April 2, 2013 - 1:53am #1

In Cloud reco sample code given, I added a new database and have given the Client Access keys to the CloudReco.h, as soon as I open the file itself it shows error. Then I run the jni folder by C/C++ Code Analysis, many files in the jni folder show error.  Can anyone tell me how to get resolved on this error

In Cloudreco sample, addition of new database shows error

April 3, 2013 - 3:14am #9

that's ok.  Then where to provide the details like target ID, title & bookUrl....i.e. how to create a new json and provide new url to it....I want after Image recognition to forward to a weblink that I specify

In Cloudreco sample, addition of new database shows error

April 3, 2013 - 1:59am #8

No, that metadata is wrong, your metadata MUST ONLY CONTAIN this line:

samplebook1.json

Everything else is not needed.

Please check the article carefully:

https://developer.vuforia.com/forum/faq/cloud-reco-how-do-i-use-my-cloud-database-sample

 

In Cloudreco sample, addition of new database shows error

April 3, 2013 - 1:47am #7

I updated the metadatafile like this,

 

samplebook1.json {
 "targetid":"aee1e5e0cb3443e6a793c7fa8e891509",
    "title": "VAISHNAVAM", "bookUrl": "http://www.ramanuja.org/"
  }
 
but also again the same problem occurs while I run it.  Is metadatafile correct now, also is there any other changes that I have to make in the code.  Please tell me.

In Cloudreco sample, addition of new database shows error

April 3, 2013 - 12:30am #6

Hi,

the CloudReco sample only accepts some sample-specific metadata tor etrieve book data;

in practice you need to put the following line of text in your metadata file that you upload:

samplebook1.json

Nothing else. Then it should work with the sample data.

Alternatively, you can also put:

samplebook2.json

or

samplebook3.json

You may also want to check this page:

https://developer.vuforia.com/forum/faq/cloud-reco-how-do-i-use-my-cloud-database-sample

 

In Cloudreco sample, addition of new database shows error

April 3, 2013 - 12:25am #5

In the same application I changed the keys, and used the following in the metadata file,

 

 {
 "targetid":"aee1e5e0cb3443e6a793c7fa8e891509",
    "title": "VAISHNAVAM", "bookUrl": "http://www.ramanuja.org/"
  }
 
On running the application, it scans, and "requesting" toast is seen after scanning the right image and loading symbol comes, but no data is read from the metadatafile and hence no forwarding the mentioned URL is made (then after loading symbol, it scans again and again).  Can you tell me where would be the mistake ?

In Cloudreco sample, addition of new database shows error

April 2, 2013 - 5:35am #4

Hi, if you changed the name of your application (and probably also the package and the class names, I presume), then it is possible you might have broken something....

I would first try just replacing the keys in the existing sample, and then move on gradually...

 

In Cloudreco sample, addition of new database shows error

April 2, 2013 - 5:30am #3

The thing is that I copied the application into a new one, and changed the name, and then the Client Access Keys in CloudReco.h and changed in the class file corresponding  to the metadatafile I uploaded.  Would it have caused an error...

In Cloudreco sample, addition of new database shows error

April 2, 2013 - 4:55am #2

Hi, have you been able to build the original sample (before changing the Keys);

did it also show errors ?

 

Log in or register to post comments