Log in or register to post comments

Error while running a sample code.

November 10, 2011 - 7:19am #1

I'm getting below error while running the ImageTargets Sample code given in development folder.Please guide me with this.

Thanks in advance

java.lang.UnsatisfiedLinkError: getOpenGlEsVersionNative
com.qualcomm.QCARSamples.ImageTargets.ImageTargets.getOpenGlEsVersio
11-10 20:37:35.396: ERROR/AndroidRuntime(6173): at com.qualcomm.QCARSamples.ImageTargets.ImageTargets.getInitializationFlags(ImageTargets.java:278)
11-10 20:37:35.396: ERROR/AndroidRuntime(6173): at com.qualcomm.QCARSamples.ImageTargets.ImageTargets.onCreate(ImageTargets.java:253)
11-10 20:37:35.396: ERROR/AndroidRuntime(6173): at android.app.Instrumentation.callActivityOnCreate(Instrumentation.java:1093)
11-10 20:37:35.396: ERROR/AndroidRuntime(6173): at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:1794)
11-10 20:37:35.396: ERROR/AndroidRuntime(6173): at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:1851)
11-10 20:37:35.396: ERROR/AndroidRuntime(6173): at android.app.ActivityThread.access$1500(ActivityThread.java:132)
11-10 20:37:35.396: ERROR/AndroidRuntime(6173): at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1038)
11-10 20:37:35.396: ERROR/AndroidRuntime(6173): at android.os.Handler.dispatchMessage(Handler.java:99)
11-10 20:37:35.396: ERROR/AndroidRuntime(6173): at android.os.Looper.loop(Looper.java:143)
11-10 20:37:35.396: ERROR/AndroidRuntime(6173): at android.app.ActivityThread.main(ActivityThread.java:4277)
11-10 20:37:35.396: ERROR/AndroidRuntime(6173): at java.lang.reflect.Method.invokeNative(Native Method)
11-10 20:37:35.396: ERROR/AndroidRuntime(6173): at java.lang.reflect.Method.invoke(Method.java:507)
11-10 20:37:35.396: ERROR/AndroidRuntime(6173): at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:839)

Re: Error while running a sample code.

November 10, 2011 - 8:08pm #2

Looks like you need to run the "ndk-build" command to build the shared libraries. See the Getting Started Guide Step 3 for more details.

Then try refreshing the Eclipse project (right-click in the Package Explorer and choose Refresh).

- Kim

Log in or register to post comments