Log in or register to post comments

Failed to load tracker data.

March 28, 2012 - 11:37pm #1

Hi everyone!

i have a problem when i change imagetarget from StonesAndChips to config (created TMS) as follow

JNIEXPORT int JNICALL
Java_com_qualcomm_QCARSamples_ImageTargets_ImageTargets_loadTrackerData(JNIEnv *, jobject)
{
LOG("Java_com_qualcomm_QCARSamples_ImageTargets_ImageTargets_loadTrackerData");

// Get the image tracker:
QCAR::TrackerManager& trackerManager = QCAR::TrackerManager::getInstance();
QCAR::ImageTracker* imageTracker = static_cast<:imagetracker>(
trackerManager.getTracker(QCAR::Tracker::IMAGE_TRACKER));
if (imageTracker == NULL)
{
LOG("Failed to load tracking data set because the ImageTracker has not"
" been initialized.");
return 0;
}

// Create the data sets:
dataSetStonesAndChips = imageTracker->createDataSet();
if (dataSetStonesAndChips == 0)
{
LOG("Failed to create a new tracking data.");
return 0;
}
/*
dataSetTarmac = imageTracker->createDataSet();
if (dataSetTarmac == 0)
{
LOG("Failed to create a new tracking data.");
return 0;
}
*/
// Load the data sets:
if (!dataSetStonesAndChips->load("config.xml", QCAR::DataSet::STORAGE_APPRESOURCE))
{
LOG("Failed to load data set.");
return 0;
}
/*
if (!dataSetTarmac->load("Tarmac.xml", QCAR::DataSet::STORAGE_APPRESOURCE))
{
LOG("Failed to load data set.");
return 0;
}
*/
// Activate the data set:
if (!imageTracker->activateDataSet(dataSetStonesAndChips))
{
LOG("Failed to activate data set.");
return 0;
}

LOG("Successfully loaded and activated data set.");
return 1;
}

and ndk build is good
but i build to .apk and run on x10i then show error "Failed to load tracker data"

Please help me error. Thank so much!

Failed to load tracker data.

August 28, 2013 - 5:22am #17

Note:

the issue may also be originated from the fact that you might need to change the file permission of the dat and XML dataset files;

see this thread:

https://developer.vuforia.com/forum/android/failed-load-dataset-testxml#comment-2031931

 

Failed to load tracker data.

August 26, 2013 - 5:37am #16

Is there any targets with zero_stars rating in your database ?

Also, SDK 2.0.31 is not able to load databases created with the latest Target Manager (so, that error is expected);

it is surprising however that you still see the same error after upgrading to SDK 2.6.

Have you tried using your dataset with the Image Targets sample of SDK 2.6 ?

 

 

Failed to load tracker data.

August 25, 2013 - 11:41pm #15

Hi Alessandro,

Thanks for responding.

We are using  Vuforia SDK V2.0.30. And yet we are getting the error " Failed to load dataset". The latest SDK available on the Vuforia website is 2.6.10. Is there a difference that we need to take care of?

Also we would like to know if qcar_config.xsd has evolved since V2.0.30. Just wondering if this could have led to this error? We have now downloaded V2.6.10 and tried. We are still getting the same error.

Request your support in resolving this issue.

Thanks

Srinivas

Failed to load tracker data.

August 23, 2013 - 10:13am #14

Hi srini1290 and bmsbanglore,

are you using an app based on the SDK V 1.5 ?

If that's the case, newly created datasets (created with latest Target Manager) will not work, as V 1.5 is no longer supported; in this case, I would recommend to upgrade to the latest version of the SDK. This link would be of help:

https://developer.vuforia.com/forum/android/migrating-sdk-15-2x

 

 

Failed to load tracker data.

August 22, 2013 - 10:51pm #13

Hi,

Even I'm facing the same problem mentioned by @bmsbangalore.

Can anybody me help with this issue?

Thanks,

Srinivas

Failed to load tracker data.

August 1, 2013 - 6:47pm #12

Hi,

I was able to change the Sample Image tracker with my own Tracker data got using Target Manager's Deveice Database.I followed the steps from this link 

https://developer.vuforia.com/forum/faq/android-how-do-i-replace-dataset-image-targets-sample.

But Last two days Am getting the "Failed to load tracker data." error when i change My Own Tracker data. I have tried all below 

- uninstalling the App from your device

- manually removing the /.libs  ./bin and  ./obj directories from your project 

- rebuilding with ndk-build 

- refreshing the project in Eclipse

- running

 

Still am getting same error if i open the application. But if i use previous Image tracker (My Own Old Image Tracker data) data's it is working fine.. Please help me..

Why latest Image Tracker data's producing this issue. I have build this Image tracker data Last two days.

Failed to load tracker data.

May 30, 2013 - 4:42am #11

I'm referring to Log messages, not log files;

i.e. you should try to debug the issue by adding more output messages in your c++ code, as it is otherwise hard to tell what goes wrong.

Also, if you cannot sort it out, I would suggest to maybe try to redo the process from scratch, starting from a fresh new ImageTargets sample, again as described here:

https://developer.vuforia.com/forum/faq/android-how-do-i-replace-dataset-image-targets-sample

Note: I tried the procedure indicated here above many times, without issues, so it should work.

 

Failed to load tracker data.

May 29, 2013 - 9:20pm #10

Hi

 yes iam sure the xml/date  file  be in assets  floder,

 

 

what is the extra log files of c++

Failed to load tracker data.

May 29, 2013 - 11:20am #9

I see. 

I would recommend debugging the issue by adding some additional logs in the native code (C++);

you need to identify where exactly is the problem (e.g. is it failing because it does not find the XML / DAT files, or maybe something else...)

Also, are you sure that the dataset files have been copied to the /assets directory ?

 

 

Failed to load tracker data.

May 29, 2013 - 6:27am #8

yes i uninstall the app in my device, and remove libs,objs floder manvaly,and build rebuild the app by using cygwin terrminal,and refres my project and again i run the project

 

 

but i didnt solve that one

 

Failed to load tracker data.

May 29, 2013 - 6:20am #7

Have you tried the following:

- uninstalling the App from your device

- manually removing the /.libs  ./bin and  ./obj directories from your project 

- rebuilding with ndk-build 

- refreshing the project in Eclipse

- running

?

Failed to load tracker data.

May 29, 2013 - 4:59am #6

Hi 

 

i follow all the steps what you say,but i didnt solve that one,in config the all MyImages.dat,MyImages.xml but 

 

still  i get that InitQCARtask:onPostExcute:failed to initialze the QCAR.excute in consol.

Failed to load tracker data.

May 29, 2013 - 3:08am #5

Hi Malleswari,

you may want to check this guide:

https://developer.vuforia.com/forum/faq/android-how-do-i-replace-dataset-image-targets-sample

as it explains how to enable your own datasets step by step...

Failed to load tracker data.

May 28, 2013 - 11:24pm #4

Hi   iam also face  this issues, 

 

 

 

      i  config the eco123.xml and eco.dat but still i getting the issues "failed to load tracker data when i lunch the app in device".

 

 

And getting the error like  InitQCAR::onPostExcute:Failed to initialize  QCAR.exiting. in consol of eclipse

Re: Failed to load tracker data.

March 30, 2012 - 12:43am #3

Thank Kim!

Re: Failed to load tracker data.

March 29, 2012 - 3:44pm #2

Did you place the config.xml and config.dat files in the assets folder?

- Kim

Log in or register to post comments