Log in or register to post comments

I NEED HELP! I AM A NEWBIE

August 16, 2013 - 10:38am #10

I'm new in Unity3D and Vuforia. Kindly somebody help me how to start a project specifically an IMAGE TRACKER. If there is a sample and simple IMAGE TRACKER APPLICATION, may i have a copy so that it will be my stepping stone to start my project. Thanks. :)

I NEED HELP! I AM A NEWBIE

August 16, 2013 - 11:18am #9

Here you go - https://developer.vuforia.com/resources/sample-apps

We have sample projects available for the native Android SDK and also the Unity extension, which will run on Android.

Also be sure to review the Getting Started guide to ensure that you have set up your development environment correctly - https://developer.vuforia.com/resources/dev-guide/getting-started-unity-extension

We also have a collection of video tutorials - https://developer.vuforia.com/resources/tutorials

I NEED HELP! I AM A NEWBIE

August 16, 2013 - 3:45pm #8

hi DavidBread. thank you for answering my post. it really helps me a lot. i would like to ask. what other extensions i needed to do download or update in my unity software in order to run my project in my android phone. thanks.

 

I NEED HELP! I AM A NEWBIE

August 16, 2013 - 4:05pm #7

You'll need the Android SDK installed. Follow these instructions for configuring Unity to build for Android - http://docs.unity3d.com/Documentation/Manual/android-sdksetup.html

And the Android SDK requires that the Java Development Kit is installed - http://developer.android.com/sdk/index.html#ExistingIDE

The Vuforia Unity samples contain the same plugins and libraries as the extension download, so you don't need to import that separately.

 

I NEED HELP! I AM A NEWBIE

August 18, 2013 - 12:21am #6

sir. after i downloaded the vuforia.unitypackage and installing the update. at the middle of installation there is afatal error that popo-outs. type == kMetaAssetType & pathName.find("library/metadata")!=0

I NEED HELP! I AM A NEWBIE

August 18, 2013 - 8:49am #5

Have you reverted to an earlier version of Unity? - http://forum.unity3d.com/threads/160690-Fatal-Error-type-kMetaAssetType-amp-pathName-find%28-quot-library-metadata-quot-%29-!-0

Try creating a new project and import the extension into that.

I NEED HELP! I AM A NEWBIE

August 18, 2013 - 10:00am #4

Anyone please help me to resolve this one.

 

Failed to compile Java code to DEX:
C:\Users\Doria\Documents\New Unity Project\Temp/StagingArea> java -Xmx1024M -Djava.ext.dirs="C:/Program Files/Android/android-sdk/platforms/android-18/lib/" -jar "C:/Program Files/Android/android-sdk/platforms/android-18/lib/dx.jar" --dex --verbose --output=bin/classes.dex bin/classes.jar plugins
Error: Unable to access jarfile C:/Program Files/Android/android-sdk/platforms/android-18/lib/dx.jar
 
UnityEngine.Debug:LogError(Object)
PostProcessAndroidPlayer:BuildDex(String, String) (at C:/BuildAgent/work/b0bcff80449a48aa/Editor/Mono/BuildPipeline/PostProcessAndroidPlayer.cs:622)
PostProcessAndroidPlayer:PostProcess(BuildTarget, String, String, String, String, String, String, BuildOptions) (at C:/BuildAgent/work/b0bcff80449a48aa/Editor/Mono/BuildPipeline/PostProcessAndroidPlayer.cs:237)
UnityEditor.HostView:OnGUI()
 

I NEED HELP! I AM A NEWBIE

August 18, 2013 - 10:39am #3

Have you installed the Android SDK, and the Java JDK, and configured Unity to find the Android SDK?

I NEED HELP! I AM A NEWBIE

August 18, 2013 - 11:36am #2

yes. i already have. and when i'm trying to build the project. that warning always pop out. i am using a unity 3.5.1 version

 

do i need to upgrade my version so it will read the files?

I NEED HELP! I AM A NEWBIE

August 18, 2013 - 12:34pm #1

I'm not sure, you may need to upgrade your Java installation. Take a look at this thread - http://answers.unity3d.com/questions/476995/android-compile-problems-all-of-a-sudden.html

Also see the SDK Platform support section of the Getting Started guide for Android for information on how to use the Android SDK manager, which will enable you to upgrade Android SDK versions - https://developer.vuforia.com/resources/dev-guide/step-1-setting-development-environment-android-sdk

My advice is to install Eclipse as well because it will provide useful debugging and SDK support tools, even though you're not programming Android natively.

You should also check Unity Answers to see why others have encountered this error - it's coming from Unity, not Vuforia.

Log in or register to post comments