Log in or register to post comments

ImageTarget does not recognize on the phone

September 29, 2018 - 9:56pm #1

Hello everyone, I'm creating my first AR application, I'm just looking a simple app to show a video on a Image Target.

I follow the instructions of this video: https://www.youtube.com/watch?v=MtiUx_szKbI

(This are the steps I did, maybe I did something wrong here:

1st replace main camera to AR Camera

2nd add the image target

3rd create a development key on vuforia website and copy the license key to the Unity app

4th added an image on a data base on vuforia website (rated five stars)

5th open the .unitypackage and changed in image target behaviour

6th add a quad on the imagetarget and add the video (it's a 16 seconds video)

 

Here I test the application on the Unity app on my pc and it worked well

 

7th build settings, changed to android and modified the basics player settings

8th before build the app, i added the sdk and jdk location on Unity app)

 

I transfer the app to the phone and when i opened the app, i could see the camera but doesn't recognize the imagetarget. I tried to change the texture type to default and sprite 2d and ui, but neither worked

 

I hope you can help me, thank you so much

 

ImageTarget does not recognize on the phone

October 30, 2018 - 10:16pm #2

I have the same problem, however in my case, if I exit the app and re-launch it in Android (transfer the .apk to the phone), the detection seems to be working. 

The issue doesn't happen on the UnityEditor on Windows though. 

Install your application, 1st iteration 50% of the time doesn't work, exit the app, and relaunch it and try. 

 I know this is not a LTS, but we need to find out what is causing the issue. :|

Log in or register to post comments