Log in or register to post comments

ImageTargets-2-6-7 always force close

September 8, 2013 - 10:31am #1

i tried to running a sample, for example ImageTargets, but it always force close. 
i tried to make *.so from ImageTarget, but i doesn't work, and i find another error.
please help me!!

AttachmentSize
Image icon error.png51.9 KB

ImageTargets-2-6-7 always force close

September 9, 2013 - 2:03am #7

Great!

ImageTargets-2-6-7 always force close

September 8, 2013 - 12:14pm #6

Alessandro, it doesn't work in emulator but it works perfectly in my device.

finally, thank you :')

ImageTargets-2-6-7 always force close

September 8, 2013 - 11:50am #5

Hi :D

cool!! it works. thank you :)

now libQCAR.so already exist but, it still doesn't work.
 

red line's log

09-08 18:46:23.581: E/QCAR(771): InitQCARTask::onPostExecute: Failed to initialize QCAR. Exiting.
 
failed to initialize? 

ImageTargets-2-6-7 always force close

September 8, 2013 - 11:37am #4

Hi,

the error that you get on the device is a runtime link error which is due to the fact that the build process did not work, i.e. the libraries have not been built;

and this is because, as you said, the ndk-build process failed;

so, until you don't fix that, you cannot even consider running on the device (as it can only fail).

The error that you get at ndk-build time is due to a file permission issue;

to solve that, you need to CD to you Vuforia installation directory, and type (from cygwin console):

chmod -R 777 *

This will ensure all the necessary file permissions.

After that, you can run ndk-build again, anbd this time it should work.

 

 

ImageTargets-2-6-7 always force close

September 8, 2013 - 11:14am #3

this is from my device 

09-09 01:18:33.759: E/QCAR(4351): The library libQCAR.so could not be loaded
09-09 01:18:33.759: E/QCAR(4351): The library libImageTargets.so could not be loaded
09-09 01:18:33.759: D/QCAR(4351): ImageTargets::onCreate
09-09 01:18:34.159: W/dalvikvm(4351): No implementation found for native Lcom/qualcomm/QCARSamples/ImageTargets/ImageTargets;.getOpenGlEsVersionNative ()I
09-09 01:18:34.159: W/dalvikvm(4351): threadid=1: thread exiting with uncaught exception (group=0x40111560)
09-09 01:18:34.169: E/AndroidRuntime(4351): FATAL EXCEPTION: main
09-09 01:18:34.169: E/AndroidRuntime(4351): java.lang.UnsatisfiedLinkError: getOpenGlEsVersionNative
09-09 01:18:34.169: E/AndroidRuntime(4351): at com.qualcomm.QCARSamples.ImageTargets.ImageTargets.getOpenGlEsVersionNative(Native Method)
09-09 01:18:34.169: E/AndroidRuntime(4351): at com.qualcomm.QCARSamples.ImageTargets.ImageTargets.getInitializationFlags(ImageTargets.java:383)
09-09 01:18:34.169: E/AndroidRuntime(4351): at com.qualcomm.QCARSamples.ImageTargets.ImageTargets.onCreate(ImageTargets.java:354)
09-09 01:18:34.169: E/AndroidRuntime(4351): at android.app.Instrumentation.callActivityOnCreate(Instrumentation.java:1047)
09-09 01:18:34.169: E/AndroidRuntime(4351): at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:1623)
09-09 01:18:34.169: E/AndroidRuntime(4351): at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:1675)
09-09 01:18:34.169: E/AndroidRuntime(4351): at android.app.ActivityThread.access$1500(ActivityThread.java:121)
09-09 01:18:34.169: E/AndroidRuntime(4351): at android.app.ActivityThread$H.handleMessage(ActivityThread.java:943)
09-09 01:18:34.169: E/AndroidRuntime(4351): at android.os.Handler.dispatchMessage(Handler.java:99)
09-09 01:18:34.169: E/AndroidRuntime(4351): at android.os.Looper.loop(Looper.java:130)
09-09 01:18:34.169: E/AndroidRuntime(4351): at android.app.ActivityThread.main(ActivityThread.java:3768)
09-09 01:18:34.169: E/AndroidRuntime(4351): at java.lang.reflect.Method.invokeNative(Native Method)
09-09 01:18:34.169: E/AndroidRuntime(4351): at java.lang.reflect.Method.invoke(Method.java:507)
09-09 01:18:34.169: E/AndroidRuntime(4351): at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:878)
09-09 01:18:34.169: E/AndroidRuntime(4351): at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:636)
09-09 01:18:34.169: E/AndroidRuntime(4351): at dalvik.system.NativeStart.main(Native Method)
 
and this one..
if i build with 'ndk-build'
 
ARUM@ARUM-PC /cygdrive/d/program/android-new/adt-bundle-windows-x86_64-20130219/vuforia/samples/ImageTargets-2-6-7
$ ndk-build
Gdbserver      : [arm-linux-androideabi-4.4.3] libs/armeabi/gdbserver
Gdbsetup       : libs/armeabi/gdb.setup
Gdbserver      : [arm-linux-androideabi-4.4.3] libs/armeabi-v7a/gdbserver
Gdbsetup       : libs/armeabi-v7a/gdb.setup
SharedLibrary  : libImageTargets.so
D:/Program/ANDROID-NEW/adt-bundle-windows-x86_64-20130219/android-ndk-r8/toolchains/arm-linux-androideabi-4.4.3/prebuilt/windows/bin/../lib/gcc/arm-linux-androideabi/4.4.3/../../../../arm-linux-androideabi/bin/ld.exe: ./obj/local/armeabi/libQCAR.so: No such file: Permission denied
collect2: ld returned 1 exit status
/cygdrive/d/Program/ANDROID-NEW/adt-bundle-windows-x86_64-20130219/android-ndk-r8/build/core/build-binary.mk:369: recipe for target `obj/local/armeabi/libImageTargets.so' failed
make: *** [obj/local/armeabi/libImageTargets.so] Error 1
 

 

ImageTargets-2-6-7 always force close

September 8, 2013 - 11:05am #2

Is that log coming from a device, or the Android emulator? - the emulator isn't supported by the SDK, you'll need to push your app to an Android device.

Log in or register to post comments