Log in or register to post comments

Initialization fails on second init

November 29, 2019 - 8:38am #1

Hello,

I got a problem with runing vuforia in my android app via Unity. When I first first start my Unity project on my phone everything works fine, as soon as I close the app and reopen it Vuforia fails to initialize. I think it has to do with how the unity app is closed, is there a spesific 'save' way to close vuforia in unity?

If I clear the data of the app and start it again, everything works fine again until I close it and reopen it... Maybe someone has an answer where the problem might accure. 

Error code is not giving much of an hint:

E/Vuforia (12233): Vuforia initialization failed

E/Unity   (12233): Vuforia initialization failed

E/Unity   (12233): (Filename: ./Runtime/Export/Debug/Debug.bindings.h Line: 35)

E/Unity   (12233):

E/Unity   (12233): Vuforia Engine initialization failed: INIT_ERROR

E/Unity   (12233):

E/Unity   (12233): INIT ERROR

E/Unity   (12233):

E/Unity   (12233): Failed to initialize Vuforia Engine.

E/Unity   (12233): (Filename: ./Runtime/Export/Debug/Debug.bindings.h Line: 35)

E/Unity   (12233):

I/Unity   (12233): Trackable 01_03_01 NO_POSE -- UNKNOWN

Thanks for your help

Initialization fails on second init

December 2, 2019 - 12:48am #2

Hi,

Could you provide the entire logcat when you start the application again? $ adb logcat AR:D Unity:D *:S

In addition could you please confirm the Vuforia SDK/Unity and the device?

Thank you.

Vuforia Engine Support

Log in or register to post comments