Log in or register to post comments

previously working Unity Android QCAR scene now won't initialize on device

September 17, 2011 - 9:40pm #1

Hi all,

I was working away happily on Unity/Android/QCAR. My scene was building fine on my Galaxy S2.
But that same scene was failing to initialize every time on my friend's Galaxy S2. It ran on a Galaxy 1 I tried, just fine.
So I started a new project and began rebuilding the scene from scratch to track down the issue.
In the process of doing this, my main Unity scene crashes (while compiling something, not sure if that's relevant) and now even my phone won't initialize any new builds. Archived versions of earlier builds work just fine on my phone, and still fail on the other Galaxy S2 that was failing before.

But here's where it gets weird(er).

Now nothing I do will make even the most basic QCAR scene run on my device.
If I make a clean project with a new scene with just the ARCamera object in the Hierarchy, the scene will not run on my device. It fails to initialize the camera.

I have an earlier build that still works reliably, so it's not a connection issue.

Anyone got any ideas?

Re: previously working Unity Android QCAR scene now won't initia

September 19, 2011 - 1:11pm #2

Are you using the latest version of the QCAR SDK (1.0.6)? Earlier versions are no longer supported.

Make sure your device is online the first time you run a QCAR app.

If it still isn't working, let us know what version of Unity you are using, and the specific model number of your device (Settings > About Phone).

- Kim

Log in or register to post comments