Log in or register to post comments

Problem with x86 Phones

September 23, 2015 - 12:12am #1

Dear Vuforia Team,

I'm a little confused with a problem. Maybe you can help me.

I'm using Unity 5.1.2 and Vuforia 4.2.3. I have a 3D application for Android with 2 scenes. In the first scene I have an AR Camera and I load some assets and after that I load the 2nd scene.
Everything is working fine with ARM phones (Samsung Galaxy S3 / S4, Galaxy Tab / Tab S, HTC One, Motorola G).
But with X86 phones (Dell ICONIC, Motorola SMi, Zenfone 2) a lot of things are not working.

Using OpenGL 2 :
On X86 phones, after the Unity splash screen, the application is closed on some phones, and for others I have something like that :

Screenshot_2015-09-17-16-41-06.jpg

OpenGL 2 + FAT (ARM + X86)
Same problem but for some phones, the screen is yellow ...

Screenshot_2015-09-18-09-02-19.jpg

After that I tried to Update to Unity 5.2.0f3 :
Nothing better

If I don't use OpenGL2 I have something better :
The 1st scene is loaded normally but for the 2nd scene I have the same camera problem.

Screenshot_2015-09-17-16-41-06.jpg

Are you aware of some technical issues happening only with X86 phones?

Thx a lot

Problem with x86 Phones

September 25, 2015 - 1:08am #3

Hello,

Thank you for the quick answer.

Problem solved by changing the player settings as described in your link.

 

Thanks again!!

Problem with x86 Phones

September 23, 2015 - 4:32pm #2

Can you verify that your Android Settings match these:

https://developer.vuforia.com/forum/faq/unity-player-settings

I successfully ran ImageTargets 5.0.5 using Unity 5.2.1f1 on an Android tablet with Intel Atom chip.

 

Log in or register to post comments