Log in or register to post comments

Problems getting FrameMarkers running

May 29, 2012 - 6:16am #1

I have looked at a couple of threads that seemed to cover this problem and the recommendation appeared to be clean and rebuild. I have used both ndk-build clean and the eclipse project clean to try and solve the problem to no end.

I initially had issues getting the build working until I sorted the QCAR_SDK_ROOT in the "Classpath Variables" tab under the Java preferences.

That got my ImageTargets working and I was able to get that running on my Samsung Galaxy SII.

The problem (using LogCat) seems to be that for the FrameMarkers app, QCAR.jar isn't being included in the apk (or at least I assume not) as I am getting the following in the LogCat file:

Could not find method com.qualcomm.QCAR.QCAR.requiresAlpha, referenced from method com.qualcomm.QCARSamples.FrameMarkers.FrameMarkers.initApplicationAR
VFY: unable to resolve static method 50: Lcom/qualcomm/QCAR/QCAR;.requiresAlpha ()Z
VFY: replacing opcode 0x71 at 0x000a

I have tried building for both Android 2.2 and 4.03 and get the same black screen then program exit behavior.

Why would one project (ImageTargets) work out of box (picking up QCAR library) and the second doesn't???

Re: Problems getting FrameMarkers running

May 29, 2012 - 5:33pm #3
ppreuss wrote:

Hello Asterion,

Please make sure you QCAR_SDK_ROOT is checked in the "Order and Export" tab of your project "Java Build Path". This can be found by right clicking on your project and selecting "Properties". From the properties window select "Java Build Path" on the left. In the "Java Build Path" window select the "Order and Export" tab and make sure QCAR_SDK_ROOT is checked.

Thank you,

-Peter

DOH!

Thank you for your quick response Peter.

Sure enough that simple fix sorted it.

Cheers,
A

Re: Problems getting FrameMarkers running

May 29, 2012 - 12:11pm #2

Hello Asterion,

Please make sure you QCAR_SDK_ROOT is checked in the "Order and Export" tab of your project "Java Build Path". This can be found by right clicking on your project and selecting "Properties". From the properties window select "Java Build Path" on the left. In the "Java Build Path" window select the "Order and Export" tab and make sure QCAR_SDK_ROOT is checked.

Thank you,

-Peter

Log in or register to post comments