Log in or register to post comments

Project 'XYZ' is missing required source folder 'gen'

December 17, 2012 - 10:29am #1

Hello,

 

I have tried building both the ImageTargets and Dominoes sample apps according to the instructions given, but I come across two errors.  The first is the title of this post.  The second is: "unable to resolve target 'android-16'".

 

I have tried finding anything about the 'gen' folder, and I don't know what to do.  I really can't find a folder marked 'gen' and every response to this error I've seen on the Internet already has said folder.  They just delete it and it repairs itself.

 

I haven't seen anything helpful on the forums about my second error either.

 

Any help would be appreciated.

Josh

Project 'XYZ' is missing required source folder 'gen'

December 18, 2013 - 8:07am #10

Hi!

I had the same problem a month long but with this:

 

"alternatively, you can open and edit the project.properties file and set the "target" to a lower API value (for instance to "android-8" or "android-10", etc. , depending on which API level you have installed)"

 

It works for me.

 

Thanks a lot.

Project 'XYZ' is missing required source folder 'gen'

October 3, 2013 - 6:15am #9

Hi Alessandro, it is the only error mansage showed. I downloaded other eclipse and other sdk and the problem was fixed. I got make the sample (imagetarget). But i will try to execute the steps from tutorial again to understand the error about "gen".

Project 'XYZ' is missing required source folder 'gen'

October 2, 2013 - 12:14am #8

Hi ramortis,

Eclipse shows that error message when it fails to build the project (probably due to some other errors); check the list of errors in your Problems panels at the bottom and try to see what needs to be fixed; for example, one possibility is that you may need to upgrade your android SDK version.

 

Project 'XYZ' is missing required source folder 'gen'

October 1, 2013 - 9:47pm #7

Hi AlessandroB, i am new here and i do this steps like you said ... but when i do it, the Eclipse show the mensage "R cannot be resolved to a variable". What i can do? Thanks

AttachmentSize
Image icon file.png85.84 KB

Project 'XYZ' is missing required source folder 'gen'

February 21, 2013 - 1:18pm #6

Hi,  your question is already addressed  below in this thread (please read previous posts). 

Project 'XYZ' is missing required source folder 'gen'

February 21, 2013 - 1:13pm #5

hi can any one help me with this problem 

Project 'XYZ' is missing required source folder 'gen'

You're welcome!

December 20, 2012 - 3:06am #4

You're welcome!

It worked!

December 19, 2012 - 4:52pm #3

Huzzah!

 

The suggestion you had worked (updating the API) and resolved my 'gen' problem as well.  Thanks so much!

 

Josh

Hi, the error "unable to

December 17, 2012 - 2:17pm #2

Hi, the error "unable to resolve target 'android-16'" is usually due to the fact that you have not installed the Android API level 16;

you can fix that by using the SDK Manager in Eclipse and install that API level (which corresponds to Android 4.1);

alternatively, you can open and edit the project.properties file and set the "target" to a lower API value (for instance to "android-8" or "android-10", etc. , depending on which API level you have installed) 

If you fix this, then the other issue you mention might get fixed automatically by Eclipse;

if not, then you can go to project -> properties -> Java Build Path -> go tp the  "Source" tab,  click on the "/gen" folder and Remove it, so to force Eclipse to regenerate it.

IHTH.

 

Log in or register to post comments