Log in or register to post comments

Replacing building model in ImageTargetSample

January 30, 2017 - 7:46am #1

Hi there,

 

I've been playing with the Vuforia SDK and its samples for now few days and i'm trying to replace the building model

of the ImageTarget sample by a choosen 3D shape.

 

For that, i've made a little parser that can transform .obj file in .txt file ( a file following the rules used in Buildings.txt).

I've replaced the buildings.txt by another .txt .

It works, and i can easily display different shapes, but it's not as beautiful as i expected: indeed, faces are not drawn because not used by the SampleApplication3DModel class ..

Can we do that with GLES (opengl)? If yes, how ?

You could think that my question is not related to Vuforia, but the sample manage to draw a building without giving

any faces date to the program, so did i forget something ?

I don't know how does the sample figure out without having faces coordinates how to draw the model entirely ..

 

All my questions are about the ImageTarget sample.

 

Thanks,

 

Regards,

 

romain

Replacing building model in ImageTargetSample

January 17, 2018 - 10:19am #5

How you convert .obj to .txt ?

Replacing building model in ImageTargetSample

January 17, 2018 - 10:06am #4

Hi , how you resolved that problem? I need to do the same. 

 

Replacing building model in ImageTargetSample

November 27, 2017 - 1:06am #3

Hi~ romainb, Have you solved that? and would mind share your convert script? i'm struggled for many days. 

 Thanks a lot!

Replacing building model in ImageTargetSample

January 31, 2017 - 4:23am #2

It's me again .. !

I've resolved a part of my problem by replacing GL_TRIANGE by GL_TRIANGLE_FAN  :

GLES20.glDrawArrays(GLES20.GL_TRIANGLE_FAN, 0,

                        mBuildingsModel.getNumObjectVertex());

 

but the result is not as good as i expected, the 3D shape isn't very well drawn for me,

and it does'nt look natural, like it was for the buildingModels.

To draw buildingModels, GLES20.GL_TRIANGLE is used and it works well, why isn't the same for

my own 3D shape ? does the problem come from here ?

Would anyone have an idea to help me ?

 

Thank you

 

Romain,

 

Log in or register to post comments