Log in or register to post comments

Samsung10, Initialisation Failed

July 22, 2019 - 1:54am #1

 

Hello There

We are currently developing a game for android and ios in unity, using vuforia obviously. We just recently went through compatibility testing for the game. The Game has been tested on several phones and android versions without any kind of hiccups, except for the Samsung Galaxy S10, where the initialization of vuforia fails. If it helps I can provide an apk file.

I would be thankfu for any kind of advice or hint of possible causes.

Cheers

 

Vuforia Version: 8.3.8

Unity Version: 2019.1.8f1

Device: Samsung S10

Android Version: 9

 

Samsung10, Initialisation Failed

August 9, 2019 - 8:51am #6

I set target API level to Android Oreo 8.0.

Samsung10, Initialisation Failed

July 30, 2019 - 1:14pm #5

Just wanted to share some information here that might help. I found that adding ARCore to my own project (detailed here) enabled the camera but removed autofocus from the S10 and other devices (tested on an S8, has autofocus without ARCore library but loses the feature with).

I'm currently using Vuforia 8.1.10 on Unity 2018.3 and tested with Arcore version 1.7 and 1.10 with the same results.

I'm trying to update to 2019 now to see if that fixes the autofocus issue.

Samsung10, Initialisation Failed

July 23, 2019 - 1:13pm #4

Hi



I also have problems with S10. Black screen. On older phones app works fine.

Samsung10, Initialisation Failed

July 23, 2019 - 4:54am #3

Hi,

Glad to see that you where able to solve the issue.

I've tested also on S10e and S10+ with the core samples, changing the backwards compatibility to Android7 and I was *not* able to reproduce the issue.

Although I didn't test with an S10 my assumption is that S10e is as close as possible from a HW perspective.

Could you please let me know if by example project you meant? Vuforia Core samples? and when you where able to reproduce the issue, did you use a new/clean project or your game project?

Thank you.

Vuforia Engine Support

 

Unity: 2019.1.9f1

Vuforia: 8.3.8

Samsung10, Initialisation Failed

July 22, 2019 - 7:14am #2

Building a unity project with a backwards compatibility of Android version 7 causes vuforia to fail initialization on Samsung S10 with Android Version 9(!!!). The issue can be reproduced by taking the example project, and changing the minimum required Version to Android 7. Vice versa, the problem has been fixed by changing minimum required verson to Android 4. Why ever the hell this has an impact on this exact phone.

Log in or register to post comments