Log in or register to post comments

Unity AR android app showing green screen when camera turned on

February 7, 2020 - 3:37am #1

Hello, I am facing a problem in running Unity android AR application on Emteria OS (android version 7.1.2) on Raspberry Pi3B+.

When AR app is opened and AR camera is activated, It shows green screen .

So I tried these steps,

-camera connected to Raspberry 3B+ is working well with pre-installed camera app.

-Green screen showing in my custom unity application when camera is turned on on RPI3B+ but when I run same app on my smartphone(android 10), it runs well.



-setting camera device on optimised speed mode in vuforia configuration. still app showing green screen when AR camera turned ON in RPI3B+.

-On RPI3B+, installed 'vuforia view' application from play store and when AR camera turned ON in application ,still green screen.

So I need help figuring this out. Thanks in advance for help!!

green screen image attached.

AttachmentSize
Image icon IMG_20200207_164306.jpg461.68 KB

Unity AR android app showing green screen when camera turned on

February 10, 2020 - 12:34am #2

Hi,

Unfortunately it does *not* work out of the box with an usb camera. 

We have exposed the API to connect an USB camera but you will need to write your own driver for it, which is technically challenging.

More info here: https://library.vuforia.com/content/vuforia-library/en/articles/Solution/external-camera.html

Thank you.

Vuforia Engine Support

Log in or register to post comments