Log in or register to post comments

Unresolved Inclusion the QCAR Libraries

November 22, 2012 - 9:05pm #1

Help me, i just reinstall my windows and now i try to configure vuforia SDK all over again from the Getting Started

but, i have a problem here, when i tried to import the ImageTarget Project and opened the ImageTarget.cpp, all the libraries have a yellow underline and a question mark "?" in front of the inclusions, like #include<jni.h>, #include <QCAR/ ... .h>, and all of the QCAR libraries (Unresolved Inclusions)

when i opened the Inlcude Browser, it has a message like this

The file 'ImageTargets.cpp' is currently not part of the index. For headers that ar never included, or sources that re not part of the build, consider selecting the preference 'Index all files'.

of course i already put the QCAR Environment Variables and the its path..  i wonder what is the problem?

Unresolved Inclusion the QCAR Libraries

July 12, 2013 - 8:15am #8

That was the workaround, not the solution :)

 

The solution is to place the environment variable in the ~/.profile file

 

Following the instruction of this response:

http://askubuntu.com/a/26411

 

the ~/.profile file is per-user and is read both by the graphical environment and the command line after login.

The only gotcha being that if you also has a ~/.bash_profile it will override ~/.profile

 

Anyway thanks for your responses.

Unresolved Inclusion the QCAR Libraries

July 12, 2013 - 7:55am #7

Executing eclipse from the command line is enough to make it work.

Glad to hear you found the solution.

Unresolved Inclusion the QCAR Libraries

July 12, 2013 - 7:51am #6

I (partially) reply to myself.

This was just an Environment variable issue.

 

I did setup the ANDROID_VUFORIA_HOME env variable in my .bashrc.

Launching Eclipse from the UI that .bashrc is not used and thus the ANDROID_VUFORIA_HOME doesn't exist.

 

Executing eclipse from the command line is enough to make it work.

 

I now have to find the better way of setting that environment on Linux so that it is used everywhere. If you have suggestions they are welcome. Thanks

 

Unresolved Inclusion the QCAR Libraries

July 12, 2013 - 7:27am #5

I followed those instructions but for choosing the path where to place the Samples.

 

I don't want to place all my project in the samples directory!

And I don't want my projects to depends on relative paths OUTSIDE the VCS.

 

Can you help me modify that example to being able to have absolute path (using environment variables) working in Eclipse?

Maybe its just I have to add the environment variable to Eclipse somewhere.

Thanks.

 

ps: I'm on Linux, but I doubt it matters.

 

 

Unresolved Inclusion the QCAR Libraries

July 12, 2013 - 3:52am #4

I would recommend to install the Android SDK and NDK, and the Vuforia SDk as illustrated in the Getting Started guide:

https://developer.vuforia.com/resources/sdk/android

In particular, try to install by following the suggested directory structure, as this will make your life a lot easier.

 

Unresolved Inclusion the QCAR Libraries

July 11, 2013 - 1:24am #3

I have the same exact issue.

 

Last Vuforia (2.5.7), samples version 2.5.5

 

I modified all the imports like this:

-LOCAL_SRC_FILES = ../../../build/lib/$(TARGET_ARCH_ABI)/libQCAR.so
-LOCAL_EXPORT_C_INCLUDES := $(LOCAL_PATH)/../../../build/include
+LOCAL_SRC_FILES = ${ANDROID_VUFORIA_HOME}/build/lib/$(TARGET_ARCH_ABI)/libQCAR.so
+LOCAL_EXPORT_C_INCLUDES := ${ANDROID_VUFORIA_HOME}/build/include
 
 
and defined ANDROID_VUFORIA_HOME in my PATH.
 
sdk-build compile just fine.
 
 
I then import the project in Eclipse (Add existing Android project) and add native code to it.
 
all the includes are broken.
 
I never used NDK before so this may be some basic stuff. Can you guide me in the right direction?
Thanks

Unresolved Inclusion the QCAR Libraries

November 23, 2012 - 12:38am #2

Hi, have you tried to close / reopen Eclipse after importing the project ? Sometimes this can fix the problem.

 

Log in or register to post comments