Log in or register to post comments

VideoPlayback : Need some help

February 20, 2013 - 7:12am #1

Hi , here is my problem , i want to play an video by augmented reality with videoplayback ....

So here what i've done : 

1) i put an AR camera 

2) i put An image target ( i've done other project on vuforia for android before so i know how to get it work )

3) i import an .mp4 in unity and use these 2 type of code  

      a )       var mov: MovieTexture = renderer.material.mainTexture;

 
                  mov.Play();
 
 
When i click on paly , the video work well but impossible to export the .apk ..... i'v got some error that i don't understand and correct 
 
 
     b )      function Start () {
   Handheld.PlayFullScreenMovie ("3LP_INTERNE_car_porsche_test.mp4", Color.black, FullScreenMovieControlMode.CancelOnInput);
}

I try this too cause i found on some unit forum that MovieTexture seems to not work on Android .....

But with this B) code , my video doens't launch ... don't understand why . 

i put my .mp4 in StreamingAssets/QCAR/video.mp4

 

 
If someone can help me with some solution it will be very helpfull :) Thanks 

VideoPlayback : Need some help

February 20, 2013 - 9:03am #4

Thank you.

VideoPlayback : Need some help

February 20, 2013 - 8:48am #3

sure

VideoPlayback : Need some help

February 20, 2013 - 8:41am #2

Hi, could you post this in the Unity section of the Forum (even if the issue is partially related to Android too), the overall topic is about Unity .

https://developer.vuforia.com/forum/ar-technical-discussion/unity-3-extension-technical-discussion

Thanks.

 

Log in or register to post comments