Topic locked

VUforia 3.0.9 Black screen

December 18, 2014 - 12:02am #1

Hi, I'm working on vuforia 3.0.9 and i have added a seperate scene for the ui and vuforia and when I run my app on kitkat 4.4.4 it shows black screen without starting the vuforia(In UI scene). When I remove the vuforia filea and run only the UI it works fine and running the vufoiar in seperate project it shows black screen and hangs.

I'm working in unity 4.5.2.

Android device moto G kitkat 4.4.4

Vuforia 3.0.9

Works fine in other Android versions.

VUforia 3.0.9 Black screen

March 9, 2015 - 8:21pm #14

This thread is specific for the Android Moto G running 4.4.4.

For the iOS issue it appears that you are having, please see this post:

https://developer.vuforia.com/forum/ios/no-camera-image-unity-ipad-air-2#comment-2048402

 

VUforia 3.0.9 Black screen

March 9, 2015 - 7:30am #13

Hello.  I am all of a sudden having this same problem on iOS through Unity. I have been all over the forums here and have seen that lots of folks are having this issue. I've tried a few different things that have been posted here but have had no luck getting this to work again. I will ultimately be creating an Android build of this same update, iOS is my client's priority and the focus will stay there until this problem is solved.

Here is the information about my hardware and software that I'm using and what's going on:

Unity 4.6.3f1

Xcode 6.1.1

iPhone 6 plus 8.1.3

ipad air 8.1.2

I have an ongoing public facing project for a client that has been available in the iOS app store and in Google Play for almost 2 years.  We've been updating it and supporting it regularly since its initial release.

I migrated the project to Vuforia 3.0.9 (after backing up as always) about a month ago and things still worked fine. The only changes that have been made to the project in the last month have been to the main menu UI and not the AR viewer portion of the app.

All of a sudden, for reasons I cannot understand, iOS builds now run with the infamous black screen. My UI shows up over top of it but no video from the camera. I have gone into settings on each device and made sure that camera is allowed for my app.  (I've even toggled it on and off to see if it would kick things on. No luck.) Stranger still, if I point my device (all in black) at one of my markers, the augment shows up over black. So I believe Qcar is working.

I am well aware of the UISupportedInterfaceOrientations crash bug in Vuforia 3.0.9 and I know how to fix it. That is not the issue. (See liwei1dao's post at this thread: http://forum.unity3d.com/threads/unity-4-6-0b20-vuforia-3-0-9-ios-exc_bad_access.274387/)  

I have attempted AlessandroB's fix posted here: https://developer.vuforia.com/forum/device-support/black-screen-ios-devices-camera-mode  and that also did not work. (Again, the augments in my project do appear over black when my device's camera is pointed at the markers.)

The app does not crash while running when not tethered to Xcode, just no video feed from the camera. However, when in Xcode, it will throw up an EXC_BAD_ACCESS. I've attached a screenshot.

I have made all of my client's changes and this latest update is now done and ready to be published. A lot of work has gone into this project in the last month and I would very much like to see it published (as would my client!)  This black screen problem is now holding everything up.

I know that ultimately this project will need to migrate to 4.0 but I would like to push this one out with 3.0.9 for now. I'm still trying to decide the best way to brake the news to my client about that whole thing.

Any help is greatly appreciated!!

VUforia 3.0.9 Black screen

January 26, 2015 - 4:47pm #12

I've tested the Vuforia sample apps with a Moto G with 4.4.4 and have not been able to reproduce any black screen issues. If you are still having problems, please provide exact steps to reproduce using one of our sample apps.

 

VUforia 3.0.9 Black screen

January 19, 2015 - 10:36pm #11

I tried all the samples from vuforia. 

VUforia 3.0.9 Black screen

January 19, 2015 - 12:23pm #10

Which one of the Vuforia sample apps was affected by this issue? Could you post a screenshot?

VUforia 3.0.9 Black screen

January 7, 2015 - 9:26pm #9

Hi,

Yes this is the device on which i'm facing the issue.

Thanks

VUforia 3.0.9 Black screen

January 7, 2015 - 12:09pm #8

Hi again,

could you confirm your Moto G device corresponds to the model reported here:

http://www.amazon.com/Motorola-Moto-Global-Unlocked-Black/dp/B00GWR373M

?

VUforia 3.0.9 Black screen

January 4, 2015 - 5:17am #7

Thanks, we will verify and get back to you shortly.

 

VUforia 3.0.9 Black screen

January 1, 2015 - 9:11pm #6

This is my device details.

AttachmentSize
Image icon Screenshot_2015-01-02-10-39-21.png142.23 KB

VUforia 3.0.9 Black screen

January 1, 2015 - 2:56am #5

Thanks for running those tests.  Could you provide exact Model Number of your Moto G ?

 

VUforia 3.0.9 Black screen

December 29, 2014 - 5:57am #4

I tried the vuforia samples 3.0 and took the build it experiences the same issue.

VUforia 3.0.9 Black screen

December 29, 2014 - 5:04am #3

HI, I downloaded 4.6.1 and had the same Issue and tried on the 4.6.1p2 too, still experiencing the same issue.

 

VUforia 3.0.9 Black screen

December 24, 2014 - 12:47am #2

Hi,

1. can you reproduce the black screen on that device using one of the Vuforia Samples ?

2. you may also want to consider upgrading from 4.5.2 to Unity 4.5.5 patch p5, and see if the problem persists; you can find the latest 4.5.5 patch here: 

http://unity3d.com/unity/qa/patch-releases

 

Topic locked