Log in or register to post comments

Vuforia APIs not initialized Error

January 22, 2014 - 8:50am #4

Hi,

 

I'm trying to run vuforia from my application.

Vuforia is set in a library, used by my application, but on starting... : 

 

01-22 17:42:11.733: D/AndroidRuntime(23468): Shutting down VM
01-22 17:42:11.733: W/dalvikvm(23468): threadid=1: thread exiting with uncaught exception (group=0x40aa1210)
01-22 17:42:11.763: E/AndroidRuntime(23468): FATAL EXCEPTION: main
01-22 17:42:11.763: E/AndroidRuntime(23468): java.lang.RuntimeException: Unable to start activity ComponentInfo{com.example.gdxintegrationtest/com.example.gdxintegrationtest.VuforiaActivity}: java.lang.RuntimeException: Use of the Java Vuforia APIs requires initalization via the com.qualcomm.vuforia.Vuforia class
01-22 17:42:11.763: E/AndroidRuntime(23468): 	at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:1967)
01-22 17:42:11.763: E/AndroidRuntime(23468): 	at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:1992)
01-22 17:42:11.763: E/AndroidRuntime(23468): 	at android.app.ActivityThread.access$600(ActivityThread.java:127)
01-22 17:42:11.763: E/AndroidRuntime(23468): 	at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1158)
01-22 17:42:11.763: E/AndroidRuntime(23468): 	at android.os.Handler.dispatchMessage(Handler.java:99)
01-22 17:42:11.763: E/AndroidRuntime(23468): 	at android.os.Looper.loop(Looper.java:137)
01-22 17:42:11.763: E/AndroidRuntime(23468): 	at android.app.ActivityThread.main(ActivityThread.java:4448)
01-22 17:42:11.763: E/AndroidRuntime(23468): 	at java.lang.reflect.Method.invokeNative(Native Method)
01-22 17:42:11.763: E/AndroidRuntime(23468): 	at java.lang.reflect.Method.invoke(Method.java:511)
01-22 17:42:11.763: E/AndroidRuntime(23468): 	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:823)
01-22 17:42:11.763: E/AndroidRuntime(23468): 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:590)
01-22 17:42:11.763: E/AndroidRuntime(23468): 	at dalvik.system.NativeStart.main(Native Method)
01-22 17:42:11.763: E/AndroidRuntime(23468): Caused by: java.lang.RuntimeException: Use of the Java Vuforia APIs requires initalization via the com.qualcomm.vuforia.Vuforia class
01-22 17:42:11.763: E/AndroidRuntime(23468): 	at com.qualcomm.vuforia.Renderer.getInstance(Renderer.java:45)
01-22 17:42:11.763: E/AndroidRuntime(23468): 	at com.osmose.ar.vuforia.ARVuforiaEngine.onARStart(ARVuforiaEngine.java:115)
01-22 17:42:11.763: E/AndroidRuntime(23468): 	at com.example.gdxintegrationtest.VuforiaActivity.onStart(VuforiaActivity.java:78)
01-22 17:42:11.763: E/AndroidRuntime(23468): 	at android.app.Instrumentation.callActivityOnStart(Instrumentation.java:1133)
01-22 17:42:11.763: E/AndroidRuntime(23468): 	at android.app.Activity.performStart(Activity.java:4475)
01-22 17:42:11.763: E/AndroidRuntime(23468): 	at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:1940)
01-22 17:42:11.763: E/AndroidRuntime(23468): 	... 11 more
01-22 17:42:11.793: D/dalvikvm(23468): Trying to load lib /data/data/com.example.gdxintegrationtest/lib/libVuforia.so 0x413a6748
01-22 17:42:12.034: D/dalvikvm(23468): Added shared lib /data/data/com.example.gdxintegrationtest/lib/libVuforia.so 0x413a6748
01-22 17:42:12.064: I/System.out(23468): Native library libVuforia.so loaded
01-22 17:42:12.084: I/AR(23468): QCAR has been initialized successfully
01-22 17:42:12.084: I/AR(23468): QCAR SDK version 2.8.7

 

I don't understrand what I missed...

I copy-pasted the image target example, removing the UI and everuthing not neccessary for me.

 

Thanks a lot!

Vuforia APIs not initialized Error

January 22, 2014 - 9:25am #3

I already have a begin of answer : in Debug there is no crash. in Release there is this one.

Seems to be a method called asynchronously, before the renderer or something else to be ready.

Still investigating... any help or advice could be very useful !

 

thanks.

Vuforia APIs not initialized Error

January 22, 2014 - 9:25am #2

I already have a begin of answer : in Debug there is no crash. in Release there is this one.

Seems to be a method called asynchronously, before the renderer or something else to be ready.

Still investigating... any help or advice could be very useful !

 

thanks.

Vuforia APIs not initialized Error

January 23, 2014 - 2:33am #1

Got it !

I now wait for the initARDone to be called to start the 3D.

Log in or register to post comments