Log in or register to post comments

Vuforia Initialization Time

April 13, 2012 - 12:36pm #1

Since upgrading to Vuforia 1.5.9, we've experienced extended initialization times, mainly the first time the app loads. As I understand it, based on research here, this is due to Vuforia downloading information about the device / camera to provide better performance. This makes sense, and it is acceptable to have a bit of a load time the first run, for a better overall experience.

However, in some cases, it'd be helpful to speed this process up, or disable it altogether. For example, when doing rapid prototyping / development, we'll often build and run an app dozens of times per day. However, using the sample ImageTargets, without any modifications, devices we've tested take anywhere from 21 seconds to 52 seconds to initialize. Within our app, the time is even longer, sometimes taking up to 2 minutes to initialize (this appeared to be loosely coupled to the number of trackables, but I haven't done extensive testing to verify that).

This initialization time really puts a hamper on rapid development, because every minor code change requires a long initialization time, cutting into dev and testing time pretty significantly. So is there a way to disable this to aid speeding up development?

Thanks!

Re: Vuforia Initialization Time

April 18, 2012 - 10:54am #5

That is indeed the differentiation. Running without debugging does speed it up dramatically. It never even occurred to me to try that, but in hindsight, it makes sense. There is probably a lot of behind-the-scenes stuff going on in Vuforia when the debugger is running.

It'd be nice if we could pass in an initialization flag to enable or disable this, but for now, I think that is a sufficient workaround. We can run without debugging, and attach the debugger once Vuforia has initialized, bypassing the long initialization time.

Thank you for all of your help!

Re: Vuforia Initialization Time

April 17, 2012 - 5:58pm #4

I have a Galaxy Nexus 4.0.2 here. ImageTargets 1.5.9 takes about 3 seconds to start up. I'm building and running directly from Eclipse, but not debugging.

Ah, but perhaps that's the issue! I just ran again with the debugger, and indeed it took longer to start up. Are you using the debugger?

We'll look into this, but in the meanwhile can you do most of your development using "Run" instead of "Debug"?

- Kim

Re: Vuforia Initialization Time

April 17, 2012 - 1:52pm #3

Thanks for the reply. I've got a pretty good internet connection, and have actually tried it on 3G, 4G, and different WiFi connections. All have similarly slow times. I've tested on four different devices:

  • HTC Incredible (Android 2.3.4)
  • HTC Rezound (Android 2.3.4)
  • Samsung Galaxy Nexus (Android 4.0.2)
  • Motorola Droid Razr (Android 2.3.5 / 2.3.6 [upgraded it and tested again])

To test, I used the sample ImageTargets app, and using v1.0 of Vuforia, the average initialization time is 3.0 seconds. Using v1.5.9, the average initialization time on the first load is 36.6 seconds, but 2.6 seconds on any load after that.

I just tried running ImageTargets while in Airplane Mode (all network connections off), and it took 48 seconds on the HTC Incredible.

Re: Vuforia Initialization Time

April 13, 2012 - 3:24pm #2

That's surprising, I don't typically see an initialization time of more than a few seconds. Are you behind a particularly slow internet connection? I recommend WiFi during development rather than the cell network.

One option is to develop with your phone in Airplane mode. Does that speed up initialization at all?

Also, what device/OS are you testing with?

Thanks,

- Kim

Log in or register to post comments