Log in or register to post comments

Vuforia+ARCore needs to install "ARCore by Google" app as a mandatory?

November 15, 2018 - 9:50pm #1

Hi, 

If I want to use Vuforia Engine +ARCore, it needs to install "ARCore by Google" app as a mandatory?

When checking the guide of "Using ARCore with Vuforia (https://library.vuforia.com/articles/Solution/arcore-with-vuforia.html)", it describes that it just downloads the library and configures a few things then, use it.

 

When testing on Galaxy S9 Plus, I confirmed that it needs to download "ARCore by Google".

If it is a mandatory, it should reflect to the implemenation of Vuforia app.

 

Please confirm. Thanks!

 

 

 

 

 

 

 

 

Vuforia+ARCore needs to install "ARCore by Google" app as a mandatory?

March 27, 2019 - 1:38pm #9

Hello all,

It is correct that the Vuforia Extension for Unity will write ARCore parameters into the Android manifest file. This means that unless you export your app into Android Studio and build there, there is no way to remove these from the manifest file when building with Unity.

The team is aware of the issue and is investigating methods to expose this option to developers. We hope to have this resolved in our next commercial release.

Thanks for your patience, and apologies for any inconvenience.

-Vuforia Engine Support

Vuforia+ARCore needs to install "ARCore by Google" app as a mandatory?

March 26, 2019 - 11:26am #8

Hello @gsylvain,

I will bring up your request with our product management team.

Thanks,

Vuforia Engine Support

Vuforia+ARCore needs to install "ARCore by Google" app as a mandatory?

March 26, 2019 - 5:20am #7

How do you open "ARCore By Google" Install Popup??? We're really looking on how to get this feature. The Unity AR Foundation + ARCore packages are doing this natively and it works like a charm. The thing is that it isn't compatible with Vuforia. Most of our players won't have the slightest clue about having to install ARCore manually from the Google Play Store.

Vuforia+ARCore needs to install "ARCore by Google" app as a mandatory?

November 27, 2018 - 9:20am #6

Hello @cknism,

We recommend that the app's check for ARCore should all happen before the call to Vuforia::init(). Once ARCore is installed, then Vuforia::init() should be called and in theory it should just work as we dynamically load the .so from the device.

Thanks,

Vuforia Engine Support

Vuforia+ARCore needs to install "ARCore by Google" app as a mandatory?

November 20, 2018 - 4:41pm #5

Hi, @medabit

Now I understand. Thanks a lot for your response;)

I have an another question regarding this.

I want to let users to play my AR app with ARCore support if device supports it, so I open ARCore install popup manually if it is not installed. But unfortunately couldn't use ARCore support right after installing ARCore before an app re-launching at the first time. I understand Vuforia Engine needs a kind of initialization steps. But is there any other way for Vuforia Engine to recognize ARCore without re-launching, for example restart() or init() for Vuforia Engine.

In ARCore without Vuforia case, if ARCore by Google is not installed or outdated, follows below steps

App lauching -> "ARCore By Google" Install Popup -> Install -> Use app SEAMLESSLY (No restart needed)

 

It would be greatly appreciated if you could give some guides for this.

Thanks!

 

Vuforia+ARCore needs to install "ARCore by Google" app as a mandatory?

November 20, 2018 - 10:39am #4

Hello @cknism,

My understanding is that  the AAR file is not equivalent to the ARCore package downloaded from the PlayStore.

The AAR file is used to allow the app to connect to the ARCore service on the device (if available), and it contains the functionality to download it - after user consent - to install the service at runtime of the app, if device is supported. There is also changes in the Android manifest file that's necessary, but in Unity Vuforia takes care of this for the developer.

Thanks,

Vuforia Engine Support

Vuforia+ARCore needs to install "ARCore by Google" app as a mandatory?

November 17, 2018 - 9:11am #3

@medabit, Hi, same question here.

 

I also try to build an app using Vuforia+ARCore. But for this, I have to place an ARCore library aar file into my Unity project under Assets/Plugins/Android/ AND install ARCore by Google from App Store manually. If either one was not installed, Vuforia Fusion didn't work in my case.

If installing ARCore by Google from App Store is mandatory, I have to implements some code for users to install it even if I already put an ARCore library aar into Unity Project. 

My question is why both same ARCore is needed.

 

Thanks in advance.

Vuforia+ARCore needs to install "ARCore by Google" app as a mandatory?

November 16, 2018 - 2:18pm #2

Hello,

Thanks for the feedback. Vuforia not packaging ARCore with our samples was deliberate decision. This is because we do not want to our update samples each time Google releases a new version of ARCore.

There are also some legal issues with Vuforia Engine from doing this, as well, but the aforementioned comment is the primary reason.

Thanks,

Vuforia Engine Support

Log in or register to post comments