Log in or register to post comments

A weird color AR display on Oppo F9 device or more

February 12, 2020 - 9:17pm #1

I used Vuforia with Unity v. 2018.4.10f1 (64-bit) to create an AR Application on Andriod devices with Android SDK 28. After I tested with Samsung Galaxy A70(Pie version), Samsung Galaxy S10(Android Q version), ASUS Zenfone 2 and Sony Xperia Z1C (Kitkat version), it works! But after I tested with Oppo F9 (model: CPH1823) (Pie version), it appeared weird color like a first picture. Accutually should be a second picture.

After I suspected storage availability of Oppo F9 device. I cleared some data to be more than 3 GB. availability whereas my application only 25 MB. used. But, it still not work.

I tried to use video recorder feature while I was opening this app. A result is the screen was stuck but the device can track the image target correctly. It appreared a model on marker while a screen displayed same background with movable model.

I debugged the device via Unity through cable link. But, Unity console didn't has any error.

I used ADB command-line to trace back errors. It's also no error.

 

Noted: This Oppo F9 can opens camera to take photos without any problem.

 

My questions are

- What's wrong with Oppo F9 and how should I deal with it?

- What are android device limitations for AR (Unity personal with Vuforia plugin)

- Do you met this problem? if yes, could you tell me the device model names?

AttachmentSize
Image icon AR-Oppo F9.jpg190.33 KB
Image icon AR-Samsung A70.jpg142.33 KB

A weird color AR display on Oppo F9 device or more

February 18, 2020 - 7:59am #2

Hi,

Usually ARCore supported devices are supported also by Vuforia. However we do not certify each ARCore device, this means that there is a high change that the ARCore supported device will also work with Vuforia.

Below a list of devices supported by Vuforia and ARCore.

https://library.vuforia.com/articles/Solution/vuforia-fusion-supported-devices.html

https://developers.google.com/ar/discover/supported-devices

In addition please note that Vuforia at core recognizes and tracks, the rendering is done by Unity.

Thank you.

Vuforia Engine Support

Log in or register to post comments