Log in or register to post comments

Authorization error

January 5, 2013 - 5:52pm #1

 

I created a database with 2 markers CLOUD
 
When the scan, both the unity app that works sometimes but often gives me the following error
 
"Authorization error, the cloud recognition service access key are incorrect or have expired"
 
What can it be?

Authorization error

January 24, 2013 - 4:03am #35

@ garyriches: thanks for your confirmation.

Authorization error

January 24, 2013 - 4:02am #34

Hi aanandsuthar1987,

in the Cloud Reco sample app you must use the Client access keys   (note: the Server ones are only needed if you want to implement your own system to upload your image targets by using the VWS  API, i.e. without passing through the Target Manager) 

Could you try unsinstalling your app from the device, and relaunching it with the Client keys, and see if you still get the "The cloud rcognition service has been suspended." error ?

 

Authorization error

January 24, 2013 - 3:49am #33

 

1. I am just download the "Cloud Reco" code from site  then
 
2. In target manager create cloud database and add target and yes there is metadata file option I don't know what is this so I just upload a .txt file.
 
3. I got a assceesKeys.txt file   there are two pair one for server access keys and another one for Client assecc keys.
 
4. If  I use Server keys  in Class   "CRQCARutils.mm" then it shows below error
 
  Authorization error    :       The cloud recogination service access keys are incorrest or have expired.
 
 I have create these keys some hours ago and just copy-past in code
 
 
 
5. If I use Client access key in class  "CRQCARutils.mm"  then it shows below error.
 
Authorization error       The cloud rcognition service has been suspended.
 
 
I don't know where i am making mistake plz help me ....

Authorization error

January 24, 2013 - 3:34am #32

Just wanted to chip in that since your fix I've not seen the issue again. This seems to be a more isolated incident rather than a wider issue.

Authorization error

January 24, 2013 - 3:27am #31

and now When it start scaning after 1 or 2 scane its gives error message like     Authorization error       The cloud rcognition service has been suspended.

 

Authorization error

January 24, 2013 - 1:21am #30

Hi aanandsuthar1987, can you confirm the exact error message you are getting, and also how frequently (roughly) does this occur ?

Authorization error

January 24, 2013 - 1:19am #29

 

Authorization error, the cloud recognition service access key are incorrect or have expired"
 
What can it be?

 

Sounds great. Let's see if

January 9, 2013 - 7:08am #28

Sounds great. Let's see if garyriches will also chime in with updates.

GREAT JOB

January 9, 2013 - 6:23am #27

 

I did all the tests and now it works fine
 
great job guys
 
but when I let them know how much it costs to become PRO? I have many plans for my hands and I can not quantify the costs

@ ALL:about the intermittent

January 9, 2013 - 4:59am #26

@ ALL:

about the intermittent authorization failure, we have implemented a little update which should fix the problem you were seeing.

Could you try again  and let me know ?

Also, if you guys have a bit of time, it would be really really great if you could perform the tests both with the "automatic (network) time settings" and with "manual" Time settings (in this case also paying attention to always set the correct Date&Time and also the TimeZone), to see if you get any more error in any of these  cases.

 

 

 

Just set it in your

January 8, 2013 - 9:56am #25

Just set it in your smartphone (go to Settings -> time and date )

 

Just set it on your

January 8, 2013 - 9:54am #24

Just set it on your smartphone

  how do I set this in

January 8, 2013 - 9:53am #23

 

how do I set this in Unity?
 
or do I just set it in the settings of your smartphone?

I must say, so far it has not

January 8, 2013 - 9:50am #22

I must say, so far it has not happened again.  It was happening around every 15 minutes or so.

I can't see how that could be the cause as I was set to GMT time zone anyways, no time changes occured. I am leaving work now, but will be working on this all of tomorrow too so I'll keep this thread updated.

OK, great. Keep us

January 8, 2013 - 9:47am #21

OK, great. Keep us posted. 

@nezwork: if you could try the same, would be great. 

Note: I'm not sure if this will solve your issue, but it's worth trying.

 

I have now done that and will

January 8, 2013 - 8:54am #20

I have now done that and will test it for a bit. It's not every time so it's hard to reproduce, but I'm sure I'll be able to in 15 minutes or so.

@ all:could you try setting

January 8, 2013 - 8:43am #19

@ all:

could you try setting both the Time and Time-Zone manually in your devices (instead of using automatic network based time settings) and do a few more tests ?

 

ITALY

January 8, 2013 - 8:17am #18

ITALY

I'm located in London,

January 8, 2013 - 8:14am #17

I'm located in London, England and the device is configured to set the time automatically and with 24 hour time set to "ON"

Thanks - where are you

January 8, 2013 - 8:12am #16

Thanks - where are you located BTW?

It just happened again. The

January 8, 2013 - 8:11am #15

It just happened again. The transaction IDs are:

70b11e0617ee45b28d354dcff4613d91

fe849de80fd04497ad7bb6215898c8e5

ddac0921554849f988ca761f5eecd449

4caa05cf466d4fbf972b360d3adec9a6

463c775cb2b84af796223306d869eee3

db79c88d4e0543879defce430092884a

I gave up after that and checked my connection, which was working fine.

I did not keep a note of the

January 8, 2013 - 8:02am #14

I did not keep a note of the transaction IDs but I will be sure to do so in future.

The test was over a Wi-Fi conection.

If you can post transaction

January 8, 2013 - 7:59am #13

If you can post transaction IDs for the affected requests, that will be helpful. 

Also is this occuring w/ a WIFI connection a/o 3/4g network?

I also see this error. It is

January 8, 2013 - 7:21am #12

I also see this error. It is not my connectivity dropping out as I am testing that on the same device and other devices at teh same time.

keys incorrect or expired

January 8, 2013 - 5:44am #11

hi,

im using unity with the cloud recognition and i'm getting the same problem!

when i compile my project in x-code, i get that error eight out of ten times as wel. i just registered and created my first target database today, but evrything else seems to be working.

Still under

January 8, 2013 - 1:13am #10

Still under investigation...

 

Hi, what's new?

January 8, 2013 - 12:56am #9

Hi, what's new?

Thanks nezwork, we can

January 7, 2013 - 7:01am #8

Thanks nezwork,

we can now investigate your issue; I will update you as soon as possible.

I got these logs with aLogcat

January 7, 2013 - 6:21am #7

I got these logs with aLogcat directly from your phone

 

 

I/AR      ( 4557): Completed CloudReco transaction with ID 'fb8b5f1cd2b245b180468f402aff0951'
I/AR      ( 4557): Completed CloudReco transaction with ID '0d0d96d8d35a4056a8dc08a05ffb8f21'

Hi nezwork,you can get the

January 7, 2013 - 4:50am #6

Hi nezwork,

you can get the transaction ID from the Unity logs by using the ADB tool;

the adb tool will actually show the Logs in a console; to use ADB, you need to find your adb.exe, which is usually located under:

YOUR_ANDROID_SDK_DIR/platform-tools

(for instance C:/Development/Android/android-sdk/platform-tools/)

Then you can open a Cygwin terminal or a command shell (in Windows you can type "cmd" in the "Start" menu and that will launch the DOS-like command shell);

Then from the command prompt, type:

adb -logcat

Launch the application from Unity (with device connected via USB), and watch the command shell, it should display lots of messages (the logs, actually);

Among those, you should eb able to see something like the following:

01-07 13:42:21.171: I/AR(25084): Completed CloudReco transaction with ID '8e692...............'

The transaction ID is the big hex string appearing there. If you could just send me that, it would be great!

 

hi Alessandro (you are

January 7, 2013 - 2:53am #5

hi Alessandro (you are Italian?)

my account is

my project database name is arpolitikc

where can I get the "transaction ID" from UNITY?

 

Hi nezwork, ok, I see, it

January 7, 2013 - 2:12am #4

Hi nezwork,

ok, I see, it seems related specifically yo your account settings/keys;

can you share your Vuforia account email, your Cloud Project/Database name, and also a "transaction ID" of one of the transactions performed by your client while talking to the Cloud (which you can find in the Logs of the CloudReco sample app) ?

Ideally, the complete Log message that you get when you have the authorization error would help as well.

 

  hello   I do not think the

January 7, 2013 - 1:45am #3

 

hello
 
I do not think the connection
 
the problem is on the phone to me randomly while I try to be in unity
 
I also thought it was my code so I took the full sample app and I only changed the authorization codes and also that way sometimes goes and sometimes it gives me the error
 
it is as if there was a limitation that the keys than in the ap test is not

Hi nezwork, how often does it

January 7, 2013 - 1:20am #2

Hi nezwork,

how often does it happen ?

could it be (just an hypohtesis) that you're wireless connection goes intermittently up and down ?

 

Log in or register to post comments