Log in or register to post comments

getting "BadImage" for a 24bit PNG

October 8, 2015 - 6:01am #1

Hi,

I am getting an static map image from Google Maps Api using the url :

https://maps.googleapis.com/maps/api/staticmap?center=32.24443,25.7875&zoom=16&size=640x640

I am using 'ImageMagick' library to convert and save the image to 24 bit png which works. But when I post the image along with the rest of the request (headers etc.) as described in the docs, I get the response:

POST 8e83550fad74eea2b9786a2e40387a77 application/json Thu, 08 Oct 2015 12:47:05 GMT /targets{"width":640,"name":"staticmap1","image":"QzoveGFtcHAvaHRkb2NzL3Z1Zm9yaWEvc3RhdGljbWFwMS5wbmc=","application_metadata":"VnVmb3JpYSB0ZXN0IG1ldGFkYXRh","active_flag":1}Unexpected HTTP status: 422 Unprocessable Entity {"result_code":"BadImage","transaction_id":"31ea42cdb28741c295573e97c939eef1"}

The strange thing is that if I upload the same image manually through the Target Manager, then the image is uploaded successfully!

any help with that?

Thanks in advance

getting "BadImage" for a 24bit PNG

December 18, 2017 - 2:46am #3

Hi,

actually I'm having the same issue.

Anyone else? Any news or informations about this issue? Looks like a WS bug.

In case, I can give you a sample PNG I'm trying to upload using the web services.

Thanks

getting "BadImage" for a 24bit PNG

October 11, 2015 - 10:38am #2

hi, somehow now it's working. I am getting the static map from a Google URL in JPG format and the post is working!

Log in or register to post comments