Log in or register to post comments

ndk-build error in Cloud Reco

November 6, 2013 - 10:42am #1

I am getting this error in cygwin terminal when I try to ndk-build

CB3SS@CB3SS-PC /cygdrive/e/android native/CloudRecognition-2-6-7
$ ndk-build
Android NDK: ERROR:jni/Android.mk:QCAR-prebuilt: LOCAL_SRC_FILES points to a mis
sing file
Android NDK: Check that jni/../../../build/lib/armeabi/libQCAR.so exists  or tha
t its path is correct
/cygdrive/e/ndk/build/core/prebuilt-library.mk:45: *** Android NDK: Aborting
.  Stop.

 

I have successfully did ndk-build to other sample codes for example ImageTargets and VideoPlayback. So I think setting up procedure of cygwin in my computer for vuforia has no issue. Its only the sample code of CloudReco is not working properly. Even if i load the app to my device, it fails to run and stops with error after showing the Splash Screen. I tried to deploy it in several devices :( no luck.

I have added my images on the database as well and copied the Accesskey and Secret Key as they mentioned. I copied the Client Access Keys into the CloudReco.h. I haven't changed anything of the sample other than this. Is there anyone who faced same issue? Thank you in advanced.

:)

Regards

Risul

 

ndk-build error in Cloud Reco

November 7, 2013 - 12:20am #4

Sounds like something 's been messed up with that sample. Have you tried deleting the following subdirectories of the Cloud Reco sample ?

- ./bin

- ./libs

- ./obj

Then try rebuild again. If it still does not work, I'd recommend to reinstall the sample (delete the Cloud Reco dir and re-copy the origial sample from the downloaded ZIP)

 

ndk-build error in Cloud Reco

November 6, 2013 - 12:39pm #3

Thanks for reply.

Sample code compiles in Eclipse but not in Cygwin, it shows error as i mentioned in previous post. And my cygwin setup is okay I believe as other samples (VidoePlayback and ImageTarget) are being compiled and running smoothly.

and even if i dont change anything in the sample code, not even the accskey and secretkey, it still does not compile in cygiwn :(

Thanks you for your help in advanced :)

ndk-build error in Cloud Reco

November 6, 2013 - 11:48am #2

Hi, does the original Cloud Reco sample compile ?

If so, and if you just changed the access keys in CloudReco.h, you should be able to compile it, unless you have by chance made other changes to the code...

 

Log in or register to post comments