Log in or register to post comments

Multi-target problems with side-pictures

May 18, 2016 - 8:25am #1

I have a set of Multitargets of 3 different sizes:

5 small (44.0 x 44.0 x 200.0)

1 medium (44.0 x 44.0 x 295.0)

2 large (44.0 x 44.0 x 400.0)

The medium and the two large ones could upload all pictures but the 5 small ones all had the problem of not being able to upload the left and right pictures.

My images are all created in Paint by myself one after the other. The image sizes in pixels are:

small:

  • back and front: 832 x 832
  • bottom and top: 832 x 3776
  • left and right: 3776 x 832 <- These do not upload

medium:

  • back and front: 832 x 832
  • bottom and top: 832 x 5576
  • left and right: 5576 x 832

large:

  • back and front: 832 x 832
  • bottom and top: 832 x 7560
  • left and right: 7560 x 832

All images are PNG's

The largest picture is 1.06 MB and it uploaded so size should not be the issue.

The error-message that is shown is "Uploaded Image is Invalid."

 

Solution-attempts:

I have tried to convert the files in error to .jpg (size 1.52 MB) but they still don't upload. The error-message is the same.

I have tried to copy a small-top-picture, rotate it and upload it but it still doesn't upload. The error-message is the same.

 

There are two images attached here. One that works and one that doesn't. Besides their rotation I see no difference between them.

Multi-target problems with side-pictures

May 21, 2016 - 4:49am #7

Great, thank you for the help. Right now I've created a work-around where I'll use just one image-target rather than a lot of multitargets but I'll probably return to this in the future and then use correct proportions.

Multi-target problems with side-pictures

May 19, 2016 - 12:37pm #6

Thanks for the assets. I believe I've isolated the problem to the MultiTarget width, length and height. Here's what I did:

  1. Opened "back-left.png" and noted down the dimensions (3776x832)
  2. Created MultiTarget with W=832.0, H=832.0, L=3776.0
  3. Uploaded 'back-left.png" to left side of new target

This worked and I was able to repeat with another different target, as well.

Looks like you've reached a default error message in our system. It should have indicated that you have an aspect ratio issue, but instead displayed invalid image. Please carefully review the aspect ratios of your target respective to the sizes of the images.

Good luck.

https://developer.vuforia.com/library//articles/Training/Multi-Target-Guide

Multi-target problems with side-pictures

May 19, 2016 - 9:13am #5

Yes unfortunately I'm still facing this error. I've tried some different resolutions but haven't figured out what's wrong yet.

Multi-target problems with side-pictures

May 19, 2016 - 7:41am #4

Thanks. As you still facing the error and can't upload the image? Or was it a transient error?

Understood about the visual artifact with the 3D representation of MultiTargets. That is an artifact of the visualization implementation.

Multi-target problems with side-pictures

May 18, 2016 - 11:35pm #3

Hello,

 

Sure thing, it's just manually created noise-patterns only meant to be good tracking so nothing sensitive.

 

Sometimes I have gotten the error-message "An error occured while uploading the image. Please try later."

 

Another thing that's probably unrelated is that the biggest multitargets are bugged in the preview, they overfill the preview area and when you rotate the model it's sent to individual side upload.

Multi-target problems with side-pictures

May 18, 2016 - 10:51am #2

Hello,

Can you please share all of the images for which the problem was observed? I'd like to recreate the workflow as part of an RCA.

If you do not feel comfortable providing them publicly, then please PM me the assets.

Thanks.

Log in or register to post comments