Log in or register to post comments

Video Playback doesn't fill image target

January 27, 2016 - 9:05am #1

I'm new to vuforia, and was using the video playback, and it worked fine with targets that were in a rectangular shape, but if I use a square shaped target, the video won't adjust to the height, only to the width. How can I make the video adjust to height and width? It doesn't matter if the video loses quality or anything.

AttachmentSize
Image icon vuf.png157.36 KB
Image icon Screenshot_2016-01-27-10-45-16[1].jpeg485.55 KB

Video Playback doesn't fill image target

April 1, 2017 - 8:57pm #6

Assets/Scripts/VideoPlayerController.cs(90,13): error CS0103: The name `VuforiaRuntimeUtilities' does not exist in the current context

Just include using Vuforia; at the top of the script VideoPlaybackController.

Video Playback doesn't fill image target

February 4, 2016 - 9:44am #5

Create a new project, import all the packages you need, such as the Dataset and vuforia video playback, put your app key in the AR camera, activate the dataset, add an image target and add the video prefab as a child of the image target. on the image target you are going to remove the default trackable event handler and add the trackable event handler that comes in the scripts folder of vuforia (I think is in that folder if you can't find it, just use the search bar), and you'll need the script that is in this thread https://developer.vuforia.com/forum/faq/unity-how-do-i-create-simple-videoplayback-app to support the tap on the video, that script is going to be attached to the AR camera. And I think that's all.

Video Playback doesn't fill image target

February 4, 2016 - 9:38am #4

Thanks! Modifying my video aspect ratio, solved it! :)

Video Playback doesn't fill image target

February 4, 2016 - 12:42am #3

Hi

i'm new in vuforia too.

i want build a sample video playback and i using of unity 5.2.0.f3 and last vuforia sdk

and i use of this tuturial : https://developer.vuforia.com/forum/faq/unity-how-do-i-create-simple-videoplayback-app

 

everything fine but video can't play even when i check auto play in video play back behaviour 

and when i want add tap to  play i have a error in compile

this error:

Assets/Scripts/VideoPlayerController.cs(90,13): error CS0103: The name `VuforiaRuntimeUtilities' does not exist in the current context
 
where i can found another tuturial for video playback with vuforia ?

 please help me . thanks

Video Playback doesn't fill image target

February 1, 2016 - 8:10am #2

The video comes with its own aspect ratio, which correspnds to the ratio between the video frames width and height; if the Image Target aspect ratio differs from the video aspect ratio you'll need to choose whether you want to match either the width or the height, but not both at the same time.

 

Log in or register to post comments