Log in or register to post comments

Warning "Trackable lost"

March 22, 2015 - 12:48pm #1

Hey guys I still need your help =(

 

I try to work with unity und vuforia for a couple days now. I watched a video on youtube where a guy creates an android AR scene. 

I repeated all the steps but it doesnt work =(

i work with vuforia 4 and unity 4.6.3

i have done everthing exactly as the guy in the vid. i have got a 5 star rated image target. 

But my car does not appear when i run my program. 

 

But I get some warnings. please take a look I made a screenshot.

these warnings appear immediately when my webcam STARTS.

 

Like you can see in my screenshot my trackable gets LOST !!! But how can this happen ?

what can I do?

i mean...before i can show my target image to the cam the warnings appear :-/

 

https://www.youtube.com/watch?v=YvSrZqP0elQ

im stuck  for 4 days now... :-/

Please help me =(

i cant be the only one with this problem =(

 

regards

david

 

AttachmentSize
Image icon Warnings.PNG25.59 KB

Warning "Trackable lost"

July 8, 2016 - 11:12am #8

Might by a silly suggestion but in your ARCamera > Database Load Behavior Script are you checking the boxes to load your databases and activating it?

My apologies, didn't see the former replies with the proper answers.

Warning "Trackable lost"

July 1, 2016 - 8:04am #7

aryaman1994 wrote:

Make sure Load XXX is checked under Database Load Behaviour component of ARCamera, where XXX is the name of your target. Also check the Activate button that appears under it. This isn't mentioned in the tutorial for some reason. Hope it helps.

 

Oh my gosh, aryman1994!!!! you rule the world!! dude!! thank you!!!!! I've been pulling out my hair for like 5 months!!! terrible!!!!  Thank you thank you thank you!!!  So stupid easy and I didn't know what was wrong!!!!!! no, it's not in the tutorial.  Dude, for real though, thank you!!

Warning "Trackable lost"

May 18, 2016 - 2:27am #6

Make sure Load XXX is checked under Database Load Behaviour component of ARCamera, where XXX is the name of your target. Also check the Activate button that appears under it. This isn't mentioned in the tutorial for some reason. Hope it helps.

Warning "Trackable lost"

August 18, 2015 - 12:21am #5

Hi, Alessandro.

I am also facing the same issue after updating to Unity 5. I thought it might be fixed in Vuforia 5, but it isn't. With a very simple setup (ARCamera + ImageTarget + Light) the tracker is lost and never found. The only hint I got of something going wrong is a strange scale in the image target after selecting the desired one. It is fixed if a new project is created and Vuforia reimported, but I am unable to have it working again in the corrupted project.

Any ideas on what might be going on?

EDIT: After deleting the marker package files, reimporting the unitypackage downloaded from the Vuforia site and restarting Unity, the tracking is working again. I have had this issue several times, so it will probably be back. I will try to determine the conditions that trigger the bug and post them here.

EDIT 2: I think I finally discovered what is casusing the bug. I am working in a server / client platform, and I usually have two Unity instances running. To achieve this in Mac, the second instance must be opened right clicking the Unity app, selecting "Show package content" (text may vary a little, my OS is not in english) and then selecting the folder Contents/MacOS and double clicking the Unity icon. Well, the Vuforia app run in the instance opened like this is unable to track any marker. Only when I run it in the main instance it works properly.

Warning "Trackable lost"

April 24, 2015 - 2:59am #4

The "Trackable XXX lost" message is displayed when Vuforia starts, as the DefaultTrackableEventHandler (which is attached to the ImageTarget and other Trackable Prefabs by default) simply prints out that debug message at initialization;

check the code in DefaultTrackableEventHandler.cs, as it is pretty self-explanatory;

that message however is completely harmless, and does not prevent your trackables from being detected and tracked properly; if you check our samples, like dm3d suggested in his previous post,  you can see that our samples also print that message, but they do work as expected, i.e. tracking and detecting the targets.

If you see a different problem, though (e.g. your targets are not tracked), please describe the issue in detail, so that it can be reproduced.

 

Warning "Trackable lost"

April 23, 2015 - 7:23pm #3

Hi dm3d,

I do not think that it is the code's problem. I've created the exact same steps back when it was still unity 4+ with Vuforia. That was in october/november 2014. I am able to track the images and display the 3D cube.

After the latest update with vuforia and upgrading with unity3D ver 5, this issue is seen on many other users as well. What I did was very basic tutorial of importing vuforia, import marker and attaching a 3D cube to it. Nothing fancyful but it is already not working with the same error from console:"Trackable XXX lost".

I'm using mac O/S maverick all these while.

Please help to provide solution for this issue.

 

Thank you.

Warning "Trackable lost"

March 25, 2015 - 10:32am #2

You might want to compare your code to the ImageTargets sample app we provide:

https://developer.vuforia.com/downloads/samples

In addition, there are many guides and how-to articles here:

https://developer.vuforia.com/library/all-articles

https://developer.vuforia.com/forum/faq/faq

 

Log in or register to post comments