Log in or register to post comments

Aspect ratio error never mind what I try

July 16, 2015 - 11:26pm #1

Hi,

Trying to add a plain cylindrical (i.e. not conical) target.

I started off using real object dimensions but I kept on getting aspect ratio errors when trying to upload the side image.

The image is 2693x827 resolution.

This gives me the aspect ratio of: 2693 / 827 = 3.25634825

I resulted in using the pixel coordinates just to see what it would complain off as there is then less calculations that might cause rounding errors, etc maybe.

With the above mentioned image resolution, I get my top and bottom diameter:

w = 2693 / pi = 857.2085 (this is using the full value of pi and not just 3.14 as stated in some of the online documentation. Also the editor only allows 4 decimals to be added)

h = sL = 827

I use those values and create an cylindrical image target with top and bottom having the same diameter w.

When I upload this said image as the side image, I get an error saying my aspect ratio should be 3.256.

I;ve tried 'gaming' the values to make it fit into that aspect ratio, but keep on chasing my own tail as I keep on getting aspect ratio errors with different values, thus never being able to hone in on a matching golden equation that will make it work.

(also if I click "Learn More" in the error message, Chrome gives an error page complaining about too many redirects) 

Help would be appreciated.

 

Cheers!

 

 

Aspect ratio error never mind what I try

May 28, 2018 - 10:57am #4

Sorry, Can some one explain this wt more detail? :)

Aspect ratio error never mind what I try

January 10, 2018 - 3:13am #3

You saved my day, man, and you did not know it... 'till now.

 

I could not get the Cylinder target and I was getting "the image do not match the dimensions of the cylinder target" error. But I read your thread and thanks to you I got the answer.

 

My image was 2708x1288px

 

2708/ PI = 862.42

 

That is my real unit.

 

Thank you very much!

Aspect ratio error never mind what I try

July 17, 2015 - 12:00pm #2

Duh, sorry my bad: the preview of my image auto-rotated it to look correct, but in fact it was in portrait (i.e. 827x2693) and not lanscape (2693x827).

Rotated it and then the upload works fine.

 

Cheers!

Log in or register to post comments