Log in or register to post comments

android app shows only green.

May 15, 2014 - 12:42am #1
vuforia sample app shows only green color in LG F200S android phone(Optimus Vu2). See attached image. #1 is target image and #2 is screen capture of vuforia sample app.
 
* the phone has no camera problem. Same occurs in two LG F200S phones, and same occurs after factory reset and reinstalling.
 
* It might be recent Vuforia SDK Version problem. Same occurs in Vuforia Sample App, QAR Occlusion Management Demo, House Model AR App, and my own vuforia App(Android - Vuforia SDK v2.8). GolpaperAR app is ok(GolpaperAR app udated 2012.11.30. so it use old Vuforia SDK) .
 
LG F200S's Android version is upgraded to 4.1.2. for details, see LG F200S specification(http://www.gsmarena.com/lg_optimus_vu_ii_f200-4950.php).
 
I think the problem is for new version of vuforia sdk. But I can't get old version of vuforia SDK and API, So I can't test.
 
If someone send me old version of vuforia SDK and API or sample app apk using old SDK, I can test.
 
I need your help...
AttachmentSize
Image icon bug.png97.43 KB

android app shows only green.

July 22, 2014 - 11:38am #28

UPDATE:

the fix for this issue is now available in the latest SDK release 3.0.9 for Android and Unity (and related samples), which is available for download here:

https://developer.vuforia.com/resources/sdk/android

https://developer.vuforia.com/resources/sdk/unity

https://developer.vuforia.com/resources/sample-apps/features

android app shows only green.

July 22, 2014 - 6:46am #27

Thanks Barmatolog for the additional report.

The fix for this issue should arrive soon with the next forthcoming release of Vuforia 3.0.x.

See also the Sticky notice here:

https://developer.vuforia.com/forum/ar-technical-discussion/device-support

 

android app shows only green.

July 22, 2014 - 6:26am #26

Hello!

Please add this device to your database 

"samsung galaxy s4 zoom"

setting MODE_OPTMIZE_SPEED didn't help (

with MODE_DEFAULT - have green artifacts

with MODE_OPTIMIZE_SPEED - purple (see attach)

AttachmentSize
Image icon Screenshot_2014-07-10-20-16-43.png331.92 KB

android app shows only green.

June 30, 2014 - 5:19am #25

@ krista17,

by looking at the screenshot, I see that in your case the screen is NOT entirely green, but there is a sort of green-ish oblique pattern / artifact covering a part of the screen (roughly one quarter of the screen);  

this is the same issue that has been reported here recently by another developer:

https://developer.vuforia.com/forum/issues-and-bugs/artifacts-after-update

 (and it is NOT related to the "green screen" issue which is described in the this thread).

Also, you have posted a bug report here, where you describe the same problem:

https://developer.vuforia.com/forum/device-support/camera-tracking-cant-work-normal

Could you follow up in that thread ?

Thanks.

 

android app shows only green.

June 30, 2014 - 4:32am #24

AlessandroB wrote:

"This is because your device needs a specific device profile that can be found upon synchronization with a remote server."

possible for your phone is no profile

"In the meantime, feel free to continue using the MODE_OPTMIZE_SPEED mode as a valid workaround."

android app shows only green.

June 30, 2014 - 3:38am #23

hmm i try with your link

AttachmentSize
Image icon Screenshot_2014-06-30-17-39-05.png453.18 KB

android app shows only green.

June 30, 2014 - 3:32am #22

i am using your technic same
always green
hmm...
owh but i try with mode camera speed
the green gone
but the camera always black....
 

android app shows only green.

June 30, 2014 - 3:27am #21

to krista17

turn on wi-fi before installing apk

android app shows only green.

June 30, 2014 - 3:12am #20

the trouble looks like same with my trouble
but the green in my device if i give character and image target
the green campture the texture (on my device)
i am using unity 4.5.1 and vuforia extension unity 3.0.6
my device evercoss A7s

owh i download your link and my camera show green
on left down

android app shows only green.

June 26, 2014 - 1:01am #19

This is expected; you need to enable the Internet connection at least once;   after that, on subsequent runs of the App (even if you subsequently disable the connection), the green screen will not appear any more (unless you unisntall and frshly reinstall the App each time, without connection). This is because your device needs a specific device profile that can be found upon synchronization with a remote server.

 

android app shows only green.

June 26, 2014 - 12:57am #18

if installed without Wi-Fi - green screen at startup

 

android app shows only green.

June 26, 2014 - 12:55am #17

Thanks for confirming it is solved now .

 

android app shows only green.

June 26, 2014 - 12:44am #16

Hi Alessandro

1. Create new unity3d project

2. import assets vuforia-unity-android-ios-3-0-6.unitypackage

3. delete "main camera" in scene

4. add "ARCamera" prefab

5. set minimum api level 14 (android 4.0)

6. on device: enable wi-fi, delete old app with vuforia 3.0

7. Create apk, download, install and run on device Galaxy Tab 3

Result:

great picture without a green screen
mysticism :)

https://www.dropbox.com/s/be07o1mdbwef8ny/vuforia30_test.apk

android app shows only green.

June 26, 2014 - 12:16am #15

Hi vetcat, try to completely uninstall and then reinstall the App on your GT-P5220, with Internet connection enabled,

and please let me know if you still see the green screen.

 

 

 

android app shows only green.

June 25, 2014 - 3:55am #14

Thanks vetcat for the report. Adding your device to our list.

 

android app shows only green.

June 25, 2014 - 1:56am #13

Unity3d (4.5.1) + Vuforia (3.0)

Samsung Galaxy Tab 3 (GT-P5220)

android: 4.2.2

Green screen on the camera prefab by default.

If you set the mode camera mode_optimize_speed, then the problem is solved.

android app shows only green.

June 24, 2014 - 11:37am #12

@ teongleong,

we looked at the PadFone Infinity T003, but it seems there is no full-match with your reported OS version; according to the information we found, the T003 should run on Android 4.2.

Could you provide the exact device model number as it appears in the device Settings > About Device panel ? and also, could you confirm the OS version and if possible any other specifications you have about your PadFone Infinity ?

 

android app shows only green.

June 4, 2014 - 12:46am #11

Thanks teongleong, I have informed our team, they will look at it.

In the meantime, feel free to continue using the MODE_OPTMIZE_SPEED mode as a valid workaround.

 

android app shows only green.

June 3, 2014 - 8:57pm #10

Hi the model number is GT-P7500  PadFone Infinity T003

I'm running android 4.0.4  4.1.2

android app shows only green.

June 3, 2014 - 5:19am #9

Hi teongleong,

thanks for the tips about camera mode; could you also provide the exact model details of your ASUS padfone (model name/number, and installed OS version) please ?

 

android app shows only green.

June 3, 2014 - 4:59am #8

I've tried to run this sample project imagetargets-2-8-13.unitypack.

I'm using a ASUS Padfone Infinity. The camera works fine on the phone itself (front and back)

The camera also works fine on the tablet (front) however the back camera of the tablet shows up tinted green.

 

I played around a bit in the project and found that just one simple thing fixes that problem.

I just find the ARCamera, find the QCARBehaviour script attached to it, and change the "Camera Device Mode"

to MODE_OPTIMIZE_SPEED.

That fixed my problem, hope it hints at what is the real problem. 

android app shows only green.

June 1, 2014 - 6:26am #7

Hi,

the issue should have been fixed.

Could you make this test:

* uninstall any of the Vuforia samples that you had previously installed on your device for testing

* re-install fresh a Vuforia sample (SDK 2.8) of your choice

* enable Internet connection

* Run the freshly installed Vuforia sample app

* Stop the Vuforia sample app

* Run it again

Could you tell whether you still see the green screen ?

 

 

 

android app shows only green.

May 19, 2014 - 12:57am #6

Ok, thanks for confirming, I will look into this with our team:

to summarize:

  • device model: LG Optimus Vu II F200,  akas  LG Optimus Vu 2
  • device specs: http://www.gsmarena.com/lg_optimus_vu_ii_f200-4950.php
  • Android OS: 4.1.2
  • issue: green screen with Vuforia-based App
  • verified on various AR Vuforia apps, including VuforiaSamples and  ImageTargets prebuilt APK downloaded from vuforia website
  • additional info: suspect (not confirmed 100%) that issue only occurs with latest SDK 2.8 (due to testing some Apps that were based on older versions, which seem to run OK)

Will let you know as soon as I have news on this.

Thanks

 

 

 

android app shows only green.

May 19, 2014 - 12:46am #5

Same green screen.

android app shows only green.

May 19, 2014 - 12:33am #4

Ok, thanks for confirming the camera app test results.

So, could you make one last very quick test, for final confirmation:

 

android app shows only green.

May 18, 2014 - 6:34pm #3
Other camera apps are ok.
I tested two LG optimus VU2, one is for Korea Telecomm, and the other one is for SK telecom, and I tested after factory reset.
Camera Apps worked perfect... except vuforia app.
 
 

android app shows only green.

May 18, 2014 - 11:24am #2

Hi, have you tested other applications that make use of the Camera preview (and not using Vuforia) ?  

There are many things here that may go wrong, for instance a problem with the camera driver or with OpenGL driver, or other HW or SW layer of that device... I doubt this is caused  by Vuforia;   usually, if a device has some incompatibility with Vuforia, this can result in black screen / black camera,  not in a "green" screen....

 

 

Log in or register to post comments