Log in or register to post comments

Android gingerbread

May 14, 2013 - 10:08am #1

Hello I have built apk's for android using Unity tool.

 

I have tried installing these on my galaxy y samsung that runs gingerbread 2.3.6

the app does not get installed.

I've also tried on HTC explorer also. It does not get installed.

What player settings(or any ) should I change in order to run these apk's on gingerbread also.

Android gingerbread

May 17, 2013 - 9:11am #13

I see. The message seems quite sel-fexplicative; it appears that your hardware is not compliant with the Unity - Android minimum requirements:

if you search the internet you should be able to find several threads about this, for instance here is one:

http://stackoverflow.com/questions/10952192/minimum-requirements-for-unity-for-android

 

Android gingerbread

May 17, 2013 - 9:07am #12

Open any of these  links

http://i44.tinypic.com/wbf5zn.png

Android gingerbread

May 17, 2013 - 6:54am #11

Hi, for some reasons the attached image does not open.

Android gingerbread

May 17, 2013 - 6:35am #10

Hello. here's the screen shot of the error i get. I think this can explain the problem better.

AttachmentSize
Image icon error.png292.68 KB

Android gingerbread

May 16, 2013 - 6:26am #9

I'll check that out and let you know.

Android gingerbread

May 16, 2013 - 1:52am #8

Ok. 

One thing; have you tried creating a simple Unity project (with a basic scene) without using Vuforia ? do you get the same problem then ?

 

Android gingerbread

May 16, 2013 - 1:28am #7

HI.

adb detects my device and I have enabled USB debuggung on my device too.

I work on eclipse platform too. So when I connect my device and run an app oneclipse its working..

(But anyway Allesandro I've got another device Samsung galaxy S on which its working very fine. SO this wont be a major issue.)

Android gingerbread

May 15, 2013 - 1:24pm #6

Could you try opening a cmd console and executing the following command:

adb devices 

what do you get in the console ?

 

 

Android gingerbread

May 15, 2013 - 6:05am #5

Hi .

When I use the build and run option of unity, I get an error saying the device found was not compatible.

When I build and get the apk on phone and try to install, the installation runs for sometime and I get a message application not installed.

Android gingerbread

May 14, 2013 - 10:24pm #4

Hi, I don't think it is a problem with the processor;

do you get any error message from Unity saying that it could not install ?

 

Android gingerbread

May 14, 2013 - 9:42pm #3

I changed it to 2.3.3. But still its not installing. What is the required processor for the app to run?

Android gingerbread

May 14, 2013 - 10:13am #2

Hi, in Unity, from the File menu you can:

  • select Build Settings..
  • switch the Platform to Android
  • Click on Player Settings
  • go to the Inspector view of the Player Settings and set the Minimum API level to the level that you want;
    • note: even if your device Android version is 2.3, you should be able to run with any settings below that level (e.g. Android 2.2)
  • Then you can click Build and Run and it should install and run the app.

If it does not, maybe the problem is that your device is not properly connected or recognized by your system. 

 

Log in or register to post comments