Log in or register to post comments

Black screen -- MacOSX Standalone

February 2, 2017 - 11:50pm #1

Hi everyone,

I've tried to create a simple app with one scene where are a placed one ARCamera and one ImageTarget. In Editor works perfectly (is a simple recognition where a 3D Cube is shown over the ImageTarget).

When I export this app, selecting the target platform as "Mac Os X" (Standalone), I launch it getting a black screen.

I've tried to select the 3 Architectures types in Build Settings (<x86>, <x86_64> and <Universal>), checking the Graphics API's for MAC in Player Settings (<OpenGL2>, <OpenlGLCore> and <Meta (Experimental)l>).

I've tested all possible combinations between these two previous parameters, but I've not been able to display the camera in my exported app in MacOSX Standalone.

On the other hand, in the Vuforia configuraton from my ARCamera (Inspector view), in the  Webcam section, I see next warning:

  • No webcam profile has been found for your webcam model: "Cámara Facetime HD (integrada)". A default profile will be used.

I don't know if this warning is affecting the execution of the exported app.

How could I solve this problem?

Thanks in advance.

----------------------------------------------------------------

Information about my environment:

Unity  5.4.1f1 Personal

Vuforia 6.2.6

Operating System: OSX The Captain (10.11.6)

Black screen -- MacOSX Standalone

February 19, 2018 - 10:24am #5

Hello,

Mac OSX standalone is not currently a supported deployment option for Vuforia.

Thanks,

Vuforia Support

Black screen -- MacOSX Standalone

February 18, 2018 - 8:41am #4

same here

Black screen -- MacOSX Standalone

April 2, 2017 - 8:43pm #3

I have the same issue :( tried on windows and mac

 

The sad thing is that older versions of Vuforia are not available to be downloaded. I'm assuming the newest version of Vuforia is causing this problem....

Black screen -- MacOSX Standalone

March 8, 2017 - 5:46pm #2

I have the same issue... I even tried building on Unity's cloud build service and still, a black screen. Works fine for Android, but OSX is a no go. In addition to the black screen I get a error saying, "the tracker could not be initialized." Any help would be appreciated Vuforia, I see this same question unanwered in many places. THe black screen anwers that have been provided were related to Android or building for OSX on Windows... I am building for OSX on a Mac and Using Unity's Cloud Build Service.

Log in or register to post comments