Log in or register to post comments

Camera malfunction in Motorola RAZR HD (xt925)

September 17, 2013 - 12:11pm #1

Hi,

I am developing AR solutions using Unity 4.1 and Vuforia plugin 2.6.7.

I have published many apps in Google Play (https://play.google.com/store/apps/developer?id=Innovar+Group) and all of them are failing in the Motorola RAZR HD (xt925) device.

I have tested them with two xt925 devices and I've had the same error. I also tested other Unity-made apps and they're working properly.

Attached you can find some screenshots (screenshots are from El Cuerpo Humano):

  1. In the first one you can see the black background where the camera should be running. Marker is, however, detected correctly.
  2. The second one shows that the camera started showing when I put the app in background (long pressed the power button).
  3. Third screenshot shows that, when returning to the app, the camera freezes again, and the model starts ghosting again.

Any help would be appreciated.

Thanks,

Martín Coll from Innovar Group.

AttachmentSize
Image icon First414.13 KB
Image icon Second490.76 KB
Image icon Third320.09 KB

Camera malfunction in Motorola RAZR HD (xt925)

September 20, 2013 - 8:36am #6

Make sure to check all the Player Settings:

for instance, have you checked the "Resolution and presentation" panel ? one thing that might be related to your issue is the "Use 32-bit Display Buffer" checkbox and/or the "Use 24-bit Depth Buffer", and many others.

Or you could perhaps start from the working solution (the one based on the imagetargets-2-6-7 and add yours and then remove the ImageTargets sample scenes.... this should allow you to have your project working, but without the imagetargets specific stuff...)

In either case, there is probably some Unity settings that is creating troubles to your graphics card when using OpenGL ES 2.0, and this sounds pretty Unity-related... I doubt here that it comes from Vuforia.

 

Camera malfunction in Motorola RAZR HD (xt925)

September 20, 2013 - 8:13am #5

Hi,

I imported the package "imagetargets-2-6-7" into a new solution. I compiled it into the troubling device and it worked perfectly. I then copied my scene and assets to this new solution, replaced the call to Application.LoadLevelAsync in LoadingManager to point to my scene, and everything worked perfectly.

In Unity I just change settings in "Player settings", and I can't find any differences between my solution and yours. If you can give me some guidance I would really appreciate it.

As a side note, I also use VideoPlayback and it doesn't seem to work with OpenGL ES 1.x, so this isn't a viable solution.

Thanks again,

Martín.

Camera malfunction in Motorola RAZR HD (xt925)

September 20, 2013 - 7:43am #4

Hi Martin, Interesting finding.

I would really appreciate if you could quickly test one of our samples as well (for instance Image Targets) where you also have some GUI (for instance you can trigger a menu to switch dataset);

this would really help to see the criticality of the issue on those devices.

Thanks.

 

Camera malfunction in Motorola RAZR HD (xt925)

September 20, 2013 - 7:27am #3

Hi AlessandroB,

Sorry for the delay in getting back. I had experienced this issues in a second device, a Sony Xperia S, but fortunately I was able to correct it by changing Unity settings to use OpenGL ES 1.x.

I think that the issue is related with using Unity GUI and Vuforia in those particular devices with OpenGL ES 2.0, but can't tell who's fault is it.

If you need help to test this, please fell free to ask. If

Regards,

Martín.

Camera malfunction in Motorola RAZR HD (xt925)

September 18, 2013 - 12:44am #2

Hi, thanks for the report. 

Have you tried to reproduce the issue on the RAZR by creatign a fresh new project and using one of our samples (for instance, the Image Targets sample) ?

Do you also see a black screen when the sample starts up ?

 

 

Log in or register to post comments