Log in or register to post comments

DM014SH / camera becomes black except Portrait mode when using Unity.

July 8, 2013 - 11:05pm #1

When I changed the "Default  Orientation" setting of the image target sample (unity extension) to "Auto Rotation" and run it in DM014SH (Dinsey Mobile), it becomes a black screen except in Portrait mode.

However, when I run image target sample (android) in DM014SH, it works well in all rotation.

Will there be the solution?

Thanks.

 

DM014SH / camera becomes black except Portrait mode when using U

January 4, 2016 - 3:02am #17

Hi,

We encountered the same issue in Vuforia 5+Unity 5.

It works normally in Portrait mode, while the black screen occurs in Landscape. 

How to solve the issue, since OpenGL ES 1.x is not found in Unity5.  Only OpenGL ES 2 or OpenGL ES 3 can be choosed.

DM014SH / camera becomes black except Portrait mode when using U

December 9, 2013 - 1:11am #16

All right, thanks for your feedback.

 

DM014SH / camera becomes black except Portrait mode when using U

December 8, 2013 - 8:47pm #15
Hi,
 
I'm sorry for the delay in my response.
 
The problem has solved by setting the OpenGL ES 1.x !!
 
thank you for your help.

DM014SH / camera becomes black except Portrait mode when using U

November 14, 2013 - 8:34am #14

Hi ,

back to this issue, have you ever tried to build and run the app wchoosing OpenGL ES 1.x instead of OpenGL ES 2.0 ?

We have seen a similar issue on another couple of devices, and the OpenGL ES 1.x was solving the problem.

 

DM014SH / camera becomes black except Portrait mode when using U

September 11, 2013 - 12:15am #13

Thanks for the logs, I have passed them to our team for further investigation.

DM014SH / camera becomes black except Portrait mode when using U

September 10, 2013 - 10:22pm #12

Hi,

thank you for investigation.

I've attached a logcat dump file.

thanks.

AttachmentSize
Plain text icon log_DM014SH_Rotate_Issue.txt44.99 KB

DM014SH / camera becomes black except Portrait mode when using U

September 6, 2013 - 5:05am #11

Hi,

could you provide a logcat dump of the issue (when running the application in landscape mode).

?

Thanks.

DM014SH / camera becomes black except Portrait mode when using U

July 17, 2013 - 9:36am #10

Thanks for the clarification. I have brought this note up to our engineering team.

DM014SH / camera becomes black except Portrait mode when using U

July 17, 2013 - 8:28am #9
More precisely, the black screen occurs when in landscape and portrait-upsidedown with autorotation enabled.
And it was the same result without autorotation.
If I set the mode directry to landscape or portrait-upsidedown, the black screen occurs.
 

DM014SH / camera becomes black except Portrait mode when using U

July 9, 2013 - 6:23am #8

Ok, thanks. I have reported the issue to our product team for investigation.

One last question:

the black screen occurs only when in landscape, with autorotation enabled;

however, if you simply set the mode directly to Landscape (without auto rotation), does it work then ?

 

DM014SH / camera becomes black except Portrait mode when using U

July 9, 2013 - 4:52am #7

Yes, I am using unity extension 2.5.8.

DM014SH / camera becomes black except Portrait mode when using U

July 9, 2013 - 4:49am #6

And which version of the Vuforia SDK ? are you using the latest version 2.5.8 ?

 

DM014SH / camera becomes black except Portrait mode when using U

July 9, 2013 - 3:07am #5

Thank you for quick reply.

Unity version is 4.1.5.

DM014SH / camera becomes black except Portrait mode when using U

July 9, 2013 - 3:05am #4

thanks.

Forgot to ask: what version of Unity are you using ?

 

DM014SH / camera becomes black except Portrait mode when using U

July 9, 2013 - 3:03am #3

Hi, 

Thank you for reply.

Android version is 4.1.2.

And I have changed minimun api level to 2.3 or higher, but it becomes black screen except in Portrait mode.

This problem did not occur with other devices.

DM014SH / camera becomes black except Portrait mode when using U

July 8, 2013 - 11:54pm #2

Hi, what is the Android version of your device ?

and, when you build your apk in Unity, have you also changed the Minimum API level to 2.3 or higher (in the Android Player Settings) ? 

 

Log in or register to post comments