Log in or register to post comments

FOCUS_MODE_CONTINUOUSAUTO is not working on Samsung S2, but it returns TRUE!

January 24, 2013 - 2:34am #1

Hi,

I found when I set focus mode to "FOCUS_MODE_CONTINUOUSAUTO" on Samsung S2, the setFocusMode method returns TRUE.

But it is infact not working! The camera video is very blurry, it is very obvious that continuous auto focus is not working!

Touch to auto focus does work, but after triggering auto focus, when I set the focus mode back to "FOCUS_MODE_CONTINUOUSAUTO", it becomes blurry again!

I think Samsung S2 does support continuous auto focus, or if it doesn't, at least QCAR should tell me the continuous auto focus mode is not supported, then I can use touch to auto focus.

Any idea?

Thanks!

regards,

Mason Hsiung

FOCUS_MODE_CONTINUOUSAUTO is not working on Samsung S2, but it r

March 8, 2013 - 1:10am #8

Ok, that was a tricky one, but I'm glad to hear that you sorted it out ;-)

Actually it is perfectly possible that Unity resets the focus mode to a default value (which is not the same as continuous autofocus).

 

FOCUS_MODE_CONTINUOUSAUTO is not working on Samsung S2, but it r

March 8, 2013 - 12:48am #7

Hi Alessandro, no that did not make a difference, but I sort it out. It does actually set continous autofocus correctly, but in Eclipse built we have functionality that moves to different Activity right after unity loads up. Then when user goes again back to Unity activity to use AR stuff, autofocus mode is not active anymore. So I put settign continous autofocus again into OnApplicationPause() and that turns it on again. I'm not sure what does deactivate it, maybe there is some underlying functionality to stop and resume camera when leaving unity and that deactivates autofocus.

 

FOCUS_MODE_CONTINUOUSAUTO is not working on Samsung S2, but it r

March 7, 2013 - 11:13am #6

Hi stan,

have you tried setting the autofocus "required" to "true" in the manifest ?

FOCUS_MODE_CONTINUOUSAUTO is not working on Samsung S2, but it r

March 7, 2013 - 8:34am #5

Hi guys,

I'm having an issue with setting continous autofocus as well. We use Unity extension latest version. When the app is built and run directly from Unity autofocus works nicely. When we build the app from Eclipse (project is exported from unity4 and has our customizations but not touching camera) then the continous autofocus is not working. In log I can see that setting it was reported as successful. But not doing it. I checked manifest and there is set

<uses-feature android:name="android.hardware.camera.autofocus" android:required="false" />

Is there anything else we are missing?

 

Thanks

Stan.

FOCUS_MODE_CONTINUOUSAUTO is not working on Samsung S2, but it r

January 24, 2013 - 5:35am #4

Yeah, that could be an option; you may also want to search the internet for Android discussion forums on focus capabilites for Samsung S2, maybe others have met similar issues. 

FOCUS_MODE_CONTINUOUSAUTO is not working on Samsung S2, but it r

January 24, 2013 - 3:58am #3

OK, I see, so I probably will disable continuous auto focus function specifically for Samsung S2.

Thanks!

regards,

Mason Hsiung

FOCUS_MODE_CONTINUOUSAUTO is not working on Samsung S2, but it r

January 24, 2013 - 2:58am #2

Hi,

in order to establish if a specific focus mode is supported, Vuforia queries the underlying system and reports what the system tells;

so, this practically means that the device somehow reports that the continuous autofocus is supported, but probably the actual behaviour does not match the expectation;

so, this sounds more like a device-specific issue, which cannot be solved at Vuforia level.

 

Log in or register to post comments