Log in or register to post comments

LG G7 ThinQ: Ground Plane not using AR Core

October 9, 2019 - 7:20am #1

Vuforia version 8.1.11

Unity 2019.1.9f

Hi all, I'm trying to build a simple ground plane demo to an LG G7 ThinQ (model number: LG-G710awm, the Canadian equivalent to the US LG-G710vm), which is apparently supported by both Vuforia Ground Plane Tracking and ARCore.

The demo should be therefore be making use of AR Core, and it is reporting that its using PLATFORM_SENSOR_FUSION, however the Ground Plane Tracking does not appear to actually be using AR Core since the quality of the tracking is nowhere near what I have found when using ARCore directly without Vuforia. (note: I need to use Vuforia since we rely on the image and model tracking features which are currently superior to the other platforms).

I have ensured that mu Unity project is building to Android 7 (Nougat) and that it is not using the Vulkan graphics API. I have built the same project to a Google Pixel 3 and it works just fine, so I'm curious why the LG G7 is not working.

Has anyone run into this issue, or similar issues with other phones?

Thanks in advance for your help,

Luke

 

LG G7 ThinQ: Ground Plane not using AR Core

October 11, 2019 - 2:04am #3

Hi,

In the release notes for 8.1.11 under Knowm Issues there is a mention regarding this device:

When ARCore is being used on the LG G7 ThinQ and LG V30+ devices the default camera resolution in MODE_DEFAULT is set to 640x480 as 1280x720 provides inconsistent results when using GroundPlane. To use 1280x720 you can disable ARCore and use Vuforia Sensor Fusion for Device Tracking.

The issue is device specific, so my recommendation would be to use another device to test the application, the Pixel 3 seems to do the job :)

Thank you.

Vuforia Engine Support

LG G7 ThinQ: Ground Plane not using AR Core

October 9, 2019 - 7:47am #2

There is a note next to the LG G7 ThinQ on ARCore's supported devices list thating that "ARCore uses the wide angle fixed focus rear facing camera for AR tracking."

Could this be my issue? If so, is there a way to force Vuforia to use this camera? 

Log in or register to post comments