Log in or register to post comments

-solved- Galaxy S7 edge support

August 12, 2016 - 2:09pm #1

Hello,

When I build my app with see-through Gear VR (Oculus) setting, I got a grey (empty) screen after getting Vuforia splash screen. No camera running.

When I build the app with AR Camera setting "none", After the splash screen I get the camera running but no tracking detection (it runs pretty well with my webcam Inside Unity).

(Building VR app is running with oculus utilities. I can build the app and see my VR environnement). Well VR is running smoothly, but AR not at all.

Any idea? Is Samsung S7 (edge) supported? I can't find any information about this...

 

Config:

-Unity 5.4.0f3 (both 64bits and 32bits)

- latest android sdk

-latest vuforia unity package: vuforia-unity-6-0-112

 

Galaxy S7 edge support

August 19, 2016 - 11:53am #13

Hello,

Glad to hear you were able to resolve.

Thanks

Galaxy S7 edge support

August 19, 2016 - 11:18am #12

Hello,

Finally...I got it! Works fine now and I can see the charming forest in VR mode:)

Unfortunately I can't say precisely what was wrong in my settings...just tried many times and correct what was somewhere wrong.

Setup is a bit complex and the fast development of both Unity and Vuforia make difficult to have an up-to-date documentation. I found lots of tutorials and comments in the forum out of date and I spent a lot of time trying workarounds that are deprecated.

Thanks for trying to help me anyway:)

 

Galaxy S7 edge support

August 17, 2016 - 2:57pm #11

Hello,

Here are some suggestions:

  1. Confirm in the Unity build settings that you did not select OpenGL ES 3.0
  2. Please check your near-far clipping planes as they may be too short and clip out the VR scene

I'll attempt to walk through Technique #1 again using the latest SDK + samples.

BTW, any reason that you're using the 32-bit version of the Unity Editor? Vuforia 6 now supports the 64-bit Editor. I will be using that for this exercise.

Thanks

Galaxy S7 edge support

August 17, 2016 - 1:47am #10

Hello,

I tried technique #1 provided by the tutorial you mentioned.

I'm running:

- Unity 5.4.0f3 32 bits on Windows 10

-vuforia sample ARVR 6-0-112

The only change I made is setting my own target image ( replacing the stones map by my own map and its well detected by vuforia plugin).

 

What's running:

-gear VR setup with my S7 edge (no more black or grey screen at startup) ;

-target recognition;

-VR button recognition with swith to VR;

-AR button recognition with swith to AR.

 

What's not running:

VR environment remains black (the only thing that I can see is the AR button)

 

 

 

Galaxy S7 edge support

August 16, 2016 - 7:58am #9

Hello,

Have you tried the various techniques listed in the following article?

https://library.vuforia.com/articles/Solution/Integrating-Gear-VR-and-the-AR-VR-Sample-in-Unity-5-3-and-above

Note that is specifically mentions black screen issues with certain versions of Unity. I'm unclear if we tested your specific version.

Thanks

Galaxy S7 edge support

August 16, 2016 - 3:34am #8

Hi again...

someone with the same problem? Or something missing in my setup?

 

thx

Galaxy S7 edge support

August 15, 2016 - 1:07am #7

#partially SOLVED#
After 3 days I finally found an error. Something wrong in the hierarchy caused the blank screen crash. Soft is great but needs a more detailed (step by step) documentation:) I didn't understand immediately how to add properly the camera rig in the sample.

I can see now the scene in AR mode but when I select the VR mode I get a black screen with pointer on the middle. I can also see the AR button and go back to AR mode.
Why is my VR environment black?

Thanks for the replies.

Galaxy S7 edge support

August 13, 2016 - 8:23am #6

Update:
I just tried the AR VR sample package provided without any manipulation.
Blank screen with my S7 and Gear VR.
The AR camera was set by default with video see-through and vuforia cardboard (generic cardboard).
I switched to gear VR (oculus) and got a blank screen too with a message on the console (no dataset).

The only way I got something is starting from scratch, importing the vuforia package, setting the AR camera (not with see-through but with 'none' selected) and the target. Building the app with VR enabled and I get the camera image and detection but no matching position. The basic geometry linked to my target (a simple cube as sample) appears when target detection is on but with no match likely because I'very a single camera and not the stereoscopy provided with see-through settings.

Keeping testing the settings but getting a bit lost:)

Galaxy S7 edge support

August 13, 2016 - 2:22am #5

Thanks for the reply.

That's good news (my phone is supported) ...and bad news (I did something wrong in my setup).

I don't use AR VR sample package. I started from scratch, importing unity package and importing my own package with a target image for testing the app.

The detection works well in Unity and I made a build on my phone (without Gear VR see-trhough video enabled) and it works also fine. The problem appens only with Gear VR enabled...and only with AR cameras (it works well with VR scenes without enabling AR cameras).

 

 

 

 

 

Galaxy S7 edge support

August 12, 2016 - 5:05pm #4

Hello,

Thanks for the feedback. This device is explicitly supported by Vuforia for GearVR.

Have you tried running our unmodified AR/VR sample to see if the problem persists? This does not use GearVR SDK - it uses Vuforia's own inertial tracker. But the result can help isolate if this is a device issue, or an app issue.

Is it correct that you're also using Unity's in-built support for the GearVR platform?

Thanks.

Galaxy S7 edge support

August 12, 2016 - 2:44pm #3

Hi,
It's device model SM-G935F
(Update: built with both mobile and eyewear device with same result)

Galaxy S7 edge support

August 12, 2016 - 2:24pm #2

Hello,

What is the device name?

Thanks

Log in or register to post comments