Log in or register to post comments

testing on different devices

November 2, 2012 - 1:02am #9

Hi , I built a sample app with unityextension v1.5.10 and now I'm testing it on different devices . I've tested it with Nexus S(android v2.3) , Galaxy S(android v2.1) , HTC desire(android v2.1) , Sony Xperia S(android v4) , HTC chacha(android v2.3) .

it works fine with nexus s , galaxy s and htc desire . but on sony xperia s , after splash screen it shows only a black screen , and in htc chacha , when you try to run it it shows "Force Close" pop up and doesn't run the app . I'll be appreciated if you can help me with this . and although if there's any service or emulator that I can use to test the compatibility of different devices .


testing on different devices

November 2, 2012 - 2:51am #8

can you paste here the Logs that you get on Sony Xperia and HTC desire ?

(You can use the DDMS view in Eclipse, see LogCat tab, or you can do it from console via adb logcat)

Also, make sure to include all details of your failing devices (e.g. full model name of HTC Desire, is it Desire S ? or other ?)

testing on different devices

November 3, 2012 - 1:35pm #7

We've had other reports of problems w/ the XPeria S and are actively investigating this issue.

testing on different devices

November 5, 2012 - 9:59am #6

thanks , sry for delay I was testing the devices and since I don't have all of them and I have to borrow it takes time :) . but I found out most of the problem is my build . I should have set "device filter" for "galaxy ace" and "htc chacha" to "ARMv6" . here's a good link to know processor types of different devices :


the only problem now is Xperia S .  I haven't though tested my app on other xperia devices , I'm planning to do a test on an Xperia X10.

thanks so much

testing on different devices

November 9, 2012 - 5:57am #5

Good to hear that you solved it for most of your devices. 

If you find any issues with the Xperia X10, please do not hesitate to share it here.

As far as the Xperia S is concerned, that is under investigation, as DavidB mentioned already.

Have you tried the latest

December 19, 2012 - 12:14am #4

Have you tried the latest 4.0.4 build? We have a report that 4.0.4, build 6.1.A.2.45 is not longer presenting this issue.


Another quick update on

December 20, 2012 - 2:44am #3

Another quick update on Xperia S:

clearing the cache for the App (or even uninstalling/reinstalling the App) + upgrading to 4.0.4 build 6.1.A.2.45 should resolve the issue.

Thanks , I'll update and

January 11, 2013 - 5:22am #2

Thanks , I'll update and inform you about the issue .

thanks again for great support . we really appreciate it .

You're welcome. And in case

January 11, 2013 - 6:52am #1

You're welcome. And in case you still face the issue, just let me know.

Log in or register to post comments