Log in or register to post comments

UWP device issue

October 2, 2018 - 1:49pm #1

Vuforia SDK Version: 7.5.20

Description: I have an Image Target app which runs well in the unity editor and as on Android platform. The issues is that when I sideload it as an UWP app, it crashes after the splash screen

Development OS (Mac OS X, Windows, Linux): Windows 10 

Is that because I am using a surface GO and Vuforia does not support it? I tried it on my laptop and same thing happened. Please help :(

UWP device issue

December 14, 2018 - 3:43pm #5

Hello @MaxiSn,

Using Vuforia Engine SDK on personal computers (e.g. non-tablets) is not commercially supported. That being said, I'm aware of other developers who have found a way to get this to work.

Thanks,

Vuforia Engine Support

UWP device issue

December 12, 2018 - 3:11am #4

Hi medabit,

Should it worked in PCs ready for UWP apps and usb-conected webcams?

Thanks.

UWP device issue

December 11, 2018 - 2:09pm #3

Hello,

The Vuforia Engine has been extensively tested on several models of UWP tablet devices. We are not aware of any outstanding crash issues with the SDK 7.5 at this time.

@Jinnliu - All UWP devices, with embedded cameras, should support Vuforia Engine SDK's legacy features (e.g. Image Targets,Cloud Reco, etc.). The only exception is that Vuforia Advanced Features, such as Ground Plane and Model Targets, are only supported on select devices which are documented here: https://library.vuforia.com/articles/Solution/vuforia-fusion-supported-devices.html (note that the MS Surface Go is listed).

If you can provide a completed crash dump file that may be helpful in identifying whether Vuforia is the source of the crash.

Thanks,

Vuforia Engine Support

UWP device issue

December 11, 2018 - 7:09am #2

Same problem here.

I am developing a very basic AR app with Unity for UWP (for a Windows 10 desktop device), and I have been unabled to run the applicacion properly because when running it, and after asking for the permission for using the device camera, the Unity splash and the first scene is shown, but then it suddenly shuts down before the camera shows anything.

Steps:

  • Create the Visual Studio project (via Build Settings... -> Universal Windows Platform -> Build)
  • In the VS project I try tu run the app in Debug mode but it fails showing a promp with the text: "Unable to start debugging. Check your debugger settings by opening project properties and navigating to 'Configuration Properties --> Debugging'". In the Debugging properties everything seems to be ok.
  • Right click on the Solution/project -> Store -> Create App Packages... -> "I want to create packages for sideloading" -> x86 + x64 Debug (I have also tested with Release and Master)
  • After installing the app certificate via PowerShell, I run the app (the app icon can be seen on the Windows menu), it launches, asks for the camera use permision, Unity splash screen, the main scene of the unity appears, and it just shut downs.

I'm using:

  • Unity Version 2018.2.15f1 Personal
  • Vuforia Version 7.5.26
  • VS Community 2017

I've been unable to find why I can't run the app from VS in Debug mode. But most of all I don't know why the app shuts down without showing any error for some clue.

I'm also concerned about using Vuforia for UWP for a desktop Windows 10 PC (not mobile): https://developer.vuforia.com/forum/device-support/current-state-desktop-apps?sort=2

Thank you very much.

Log in or register to post comments