Topic locked

Xperia Z issue

September 27, 2013 - 2:31am #1

 

Hello, 
 
 
 
I've found an issue with Xperia Z when using Vuforia. When I install a vuforia application to my Xperia Z, the screen is all black but the app is working because I can see GUI items or even 3D models when I focus on an image target but the "camera feed" is not showing at all. 
 
I suppose that it means the device is getting the "real" image but is not showing it in the device screen for some reason.
 
I've tried another Xperia Z, to discard its a problem of my device, and it makes the same as mine. Also I tried to install a vuforia sample without editing anything and it doesn't work either. I attach two images that show the problem.
 
I installed my application to other android and iOS devices, and it works well. 
 
Is that a known issue? Have it any solution?
 
Thanks!
AttachmentSize
Package icon images.zip1.65 MB

Xperia Z issue

October 7, 2013 - 11:52pm #15

Good to hear!

Xperia Z issue

October 7, 2013 - 11:12pm #14

Solved! Seems to be a problem with my Unity version, because the native apk is working well.

When I update my unity version I'll confirm if that solves the problem, thanks!

Xperia Z issue

October 4, 2013 - 12:50am #13

Ok. One important thing:  upgrade to Unity 4.1.5 if you can, as this may fix the problem.

(if the upgrade does not solve the issue, then please run the native APK test , and let me know)

 

Xperia Z issue

October 3, 2013 - 11:30pm #12

I am using 4.0.0f Unity version.

 

I'll try to install Native Android APK as soon as I can. Thanks again!

Xperia Z issue

October 3, 2013 - 9:33am #11

Just got some feedback from our engineers, and I would have a small request for you:

  • could you download the Native Android APK of the ImageTargets sample from ehre:

https://developer.vuforia.com/resources/sample-apps/image-targets-sample-app

(see the button *"Download Android APK"*)

  • And install and run it on your Xperia device ? 

This would allow us to knwo if you are seeing the issue ONLY on Unity, or both on Unity and Native.

This information is important for us to further narrow down the issue, so it would be great if you could try this.

 

 

 

 

Xperia Z issue

October 3, 2013 - 6:47am #10

Ok, thanks, now we have a fairly complete set of information;

one last thing, as you are using the Unity extension, could you also specify what version of Unity are you using ?

 

Xperia Z issue

October 3, 2013 - 3:04am #9

I've done what you asked and It does the same, and the issue on the very first run of the sample

Thanks

Xperia Z issue

October 2, 2013 - 2:09am #8

 

Yes sorry, I confirm it's C6603 ! I misread that, that was my fault.
 
I'll try to do what you say as soon as I can, I'm not in the office at the moment and I can't use unity to reinstall the sample.
 
 
 
Thanks again.

Xperia Z issue

October 1, 2013 - 9:17am #7

Hi again,

could you make this simple test:

- disable internet connection on your device

- uninstall the sample APK from the device

- reinstall the sample on the device and run it

Do you see the issue on the very first run of the sample (after reinstalling it) ?

Also, it seems the correct model number is C6603 (and not G6603); can you confirm ?

 

Xperia Z issue

September 29, 2013 - 1:02am #6

Thanks for the model. Will check that specific device.

 

Xperia Z issue

September 27, 2013 - 11:42am #5

Sorry for the delay, the Model Number is G6603

Thanks again

Xperia Z issue

September 27, 2013 - 4:35am #4

Thanks for the info, 

concerning the model:

Snoy Xperia Z is not sufficient, as there are different models in the market, which have different "Model Number" (although they are all named Sony Xperia Z, they may have slightly different hardware components);  for example Model Number = "SGP300",  or "SGP312", ...

 

To obtain the model number of your device, you can go to Settings and then you should find something like "About Device" or "Device Info"... if you click there, you should be able to see the exact Model number identifier.

 

 

Xperia Z issue

September 27, 2013 - 3:27am #3

 

- exact model name/number: Sony Xperia Z (http://www.sonymobile.com/global-en/products/phones/xperia-z/)

- Android OS version: 4.2.2

- Vuforia SDK version: Unity extension 2.6.7

 

Thanks

 

Xperia Z issue

September 27, 2013 - 2:38am #2

Hi,

could you provide:

- exact model name/number

- Android OS version

- Vuforia SDK version ?

Thanks.

 

Topic locked