Log in or register to post comments

Adjust viewport size on Gear VR

April 8, 2015 - 1:42pm #1

So I am working with Gear VR and am having issues with the viewport sizes when building to the note 4. I have attached a screenshot of what it looks like. 

 

I couldn't find anything in the docs or in any of the prefabs that would be for adjusting this. This happens on the sample projects as well as a basic scene with only the arcamera.

How can I go about getting the eyes to display properly?

 

Unity 4.6.4f1

Oculus Mobile SDK Version 0.4.2

Vuforia Digital Eyewear Beta 4.1

AttachmentSize
Image icon Screenshot_2015-04-08-14-34-44.png1.5 MB

Adjust viewport size on Gear VR

April 21, 2015 - 4:01pm #6

Are you using setting the orientation as landscape left?

Could you provide the steps to reproduce this?

Which is your device model?

Adjust viewport size on Gear VR

April 19, 2015 - 2:47pm #5

This doesn't fix the issue that I posted about. The problem is the size is not scaling properly which makes it squish, no matter what size it is.

Adjust viewport size on Gear VR

April 15, 2015 - 9:08am #4

You can adjust the viewport size for camera see-through devices by defining a scene scale in the QCARBehaviour of the ARCamera - a setting of 0 uses the default scale, a value between 0 and 1 will reduce the viewport size proportionally.

Adjust viewport size on Gear VR

April 13, 2015 - 3:46pm #3

@all, thanks, are we the only team seeing this issue with improper horizontal sized stereoscopic windows?  Please check out screen shot below.

Adjust viewport size on Gear VR

April 12, 2015 - 12:06pm #2

Has anyone else experienced this or gotten it to work with the Gear VR?

Log in or register to post comments