Log in or register to post comments

Black Screen, just Vuforia Watermark

April 20, 2015 - 8:00am #1

Hi everyone,

  Now I am working with ODG R6 and EPSON BT-200 glasses. My issue is that when I deploy my Vuforia project to those glasses, there is a black screen with just

  Vuforia watermark on the camera, however, app starts tracking when the glasses' camera see my image target but again camera does not work just my object which I put on my image target  and Vuforia watermark are seen. I also tried that with the vuforia eyewear samples but the result is same.

- I am using;

Win 8.1

Unity 4.6.2f1

Vuforia-unity-mobile-android-ios-4-1-3-eyewear-beta (I am using Vuforia Eyewear License Key)

I also check all the network permissions of the glasses. (ODG R6 and BT-200 were working with Vuforia 3.0)

 

Does anyone who face with that sort of issue? Sorry for my english :)

 

Black Screen, just Vuforia Watermark

May 4, 2015 - 5:40pm #10

Hi,

The screenshot you attached would not be the right behavior for the see-through devices because it is rendering the background.

As you correctly mentioned in your comment rendering black would be the same as no background for see-through devices. You would notice the black background but not as in the non see-through devices, you will notice black is seen as a shadow when wearing the glasses. Note that there is no way to "not to draw" a pixel in the device display, a color has to be rendered and in this case is black.

Could you send an image of the application with black background? This time try with a camera and not with adb since with adb you will get the plain back screenshot and that would not be representative on how it looks when wearing the device.

Black Screen, just Vuforia Watermark

May 4, 2015 - 1:46am #9

Hi,

   I still do not have chance to take a screenshot because the glasses are being used by my teammates. However, I attached a photo of what I exactly see while ı am using      previous sdk of vuforia. With Vuforia 3.0.9, the video background was rendering. If I understand correctly you do not render the video background in vuforia 4.0 because     those are see-through devices so you just render black but this black background is not seen as transparent. Perhaps this black background should be seen as        transparent but in my case do not.

As soon as get the change I am going to send the real screenshots from those glasses.

Thanks for all attention :)

AttachmentSize
Image icon WM2Small.png276.76 KB

Black Screen, just Vuforia Watermark

April 29, 2015 - 11:22am #8

Can you provide a screenshot of your same scene using the previous sdk? That way I can see what you are referring to since rendering black background is the intentded behavior. As Andrew said and yourself, the background is rendered in black since in see-through devices black would be seen as transparent.

Black Screen, just Vuforia Watermark

April 29, 2015 - 9:15am #7

Let me reiterate my problem.

You are right when saying that the background rendered by Vuforia will have a black background since it will not be displayed on see-through glasses. However, the image that I see when looking through see-through glasses has a black background on it. The black background is seen both when looking for the trackable and when actually tracking the object. I see the augmentations just fine, but the black background lays over the real world view when looking through the glasses. The image that I attached previously illustrates not what is rendered by Vuforia but rather what is seen when looking through the glasses.

What is reason that I see this black background?

Kind regards,Let me reiterate my problem.

You are right when saying that the background rendered by Vuforia will have a black background since it will not be displayed on see-through glasses. However, the image that I see when looking through see-through glasses has a black background on it. The black background is seen both when looking for the trackable and when actually tracking the object. I see the augmentations just fine, but the black background lays over the real world view when looking through the glasses. The image that I attached previously illustrates not what is rendered by Vuforia but rather what is seen when looking through the glasses.

What is reason that I see this black background?

Kind regards,

Black Screen, just Vuforia Watermark

April 28, 2015 - 5:42pm #6

So what you intend to do is to render the video background in the app? As Andrew said, for the VDE devices we don't render the video background because those are see-through devices. The augmentation will be registered to the target in the real world.

Black Screen, just Vuforia Watermark

April 28, 2015 - 1:27am #5

Hi Andrew,

  This was Vuforia version 3.0.9, not the eyewear beta release. 

  That version was working perfect, you could deploy your apps to those glasses like the same way you do for any android devices, but still I could not solve my problem with video background in Vuforia 4. I tried to set the camera mode as stereo but again no difference.

Black Screen, just Vuforia Watermark

April 27, 2015 - 2:03am #4

Hello,

The screenshot looks how I would expect, the video background has been turned off as the display is see-through - anything rendered black is not seen when looking through the glasses.

Can you confirm the exact version of Vuforia 3 that you were using and whether this was an eyewear beta release?

Kind regards,
Andrew

 

Black Screen, just Vuforia Watermark

April 25, 2015 - 5:32am #3

Hi

   Sorry for the late reply, Yes this is true that I am just able to see the augmentations, Vuforia watermark and UI materials like buttons, slider, etc but all of other camera view, image target, object target, etc. are covered with black screen. So somethings seem to me wrong. When I was working with Vuforia 3, everything was working perfect on those glasses. This situation started with Vuforia 4

I attached an example picture of what I am seeing on my glasses' camera view when their cameras started to tracking.

Could it be possible that, this problem came out due to the glasses' OS versions?

 

AttachmentSize
Image icon eyewear_camera_view.png64.23 KB

Black Screen, just Vuforia Watermark

April 20, 2015 - 5:00pm #2

Hi,

If I understand correctly you are able to see the augmentations but not the camera background right? If so, for these devices we don't render the video background. These are see-through devices. If you see the augmentation correctly registered to the physical target in the real world then it is working correctly.

Log in or register to post comments